NETAPP TECHNICAL DOCUMENT

Novell GroupWise Backup with NetApp Storage
Peter Henneberry, Global Systems Engineer, NetApp
August 2008 | TR-3699

TABLE OF CONTENTS:
1 BACK UP OR RESTORE GROUPWISE ON A NETWARE 6.5 SERVER CONNECTED TO NETAPP
STORAGE 3
BACKGROUND ON NETWARE 6.5, SP5 OR HIGHER ..............................................................................................3
PRESERVING NETWARE FILE TRUSTEE INFORMATION ......................................................................................3

2

STEPS FOR A NETWARE 6.5 GROUPWISE VOLUME SNAPSHOT COPY ........................... 3
NETAPP STORAGE PREPARATION .........................................................................................................................3

3

STEPS TO RESTORE A NETWARE 6.5 VOLUME SNAPSHOT COPY .................................. 6
RESTORE NETWARE FILE TRUSTEE INFORMATION ............................................................................................6

4

TO RESTORE INDIVIDUAL FILES RATHER THAN REPLACING A VOLUME....................... 6

5

RESTORING DELETED GROUPWISE MAILBOX ITEMS ........................................................ 8
SETTING UP A RESTORE AREA ...............................................................................................................................8
RESTORING A USER’S MAILBOX ITEMS .................................................................................................................8
LETTING USERS RESTORE THEIR OWN MAILBOX ITEMS ...................................................................................9
WHEN COMPLETED WITH THE MAILBOX RESTORE .............................................................................................9
USEFUL GROUPWISE SCRIPTS ...............................................................................................................................9
GWSTRT.NCF (FOR GROUPWISE 7) ......................................................................................................................10
GWSTOP.NCF ...........................................................................................................................................................10

6

CONCLUSION .......................................................................................................................... 11

2

GroupWise Backup on NetApp storage

1

BACK UP OR RESTORE GROUPWISE ON A NETWARE 6.5 SERVER
CONNECTED TO NETAPP STORAGE

BACKGROUND ON NETWARE 6.5, SP5 OR HIGHER
•

•

•
•

When using iSCSI for the LUN connection, the Novell® iSCSI initiator defaults to one LUN per
connection. If you have more than one LUN defined on the NetApp® storage, you must set the
initiator property “Number of LUN probes per target” value to greater than or equal to the number
of LUNs to which you want to connect. This can be done on the initiator Properties page on
Novell Remote Manager (NoRM) and must be done prior to establishing the connection. If more
LUNs are added after the connection is established, the connection must be dropped and
restarted to detect the new LUNs. For more information about the initiator Properties page, see
the Novell iSCSI for NetWare® documentation.
The NetWare volume will be connected via iSCSI or FCP from the NetApp storage for block
based, or NFS if using VMware® ESX 3.5.x. VMware will then virtualize the NFS mountpoint and
present it to NetWare as block-based storage. Refer to “NetApp and VMware Virtual
Infrastructure 3 Storage” at http://media.netapp.com/documents/tr-3428.pdf.
The NetWare volume has “NSS Volume Snapshot – File Level”1 enabled.
Novell’s trustee.nlm (version 1.10.06) or newer has been copied to sys:\system; this is for file
level trustee restore.

PRESERVING NETWARE FILE TRUSTEE INFORMATION
Since trustee assignments are associated at the volume level, if a NetWare volume is backed up and
mounted on another server, the trustee rights would be lost. The goal is to allow NetWare trustee
assignments to be backed up and restored when mounted on any NetWare 6.5 within the same NDS
tree. To provide this functionality, the following command will be taken prior to creating a NetApp
Snapshot™ copy:
NetWare> TRUSTEE SAVE <volume name>: <volume name>:\trustees.txt
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STEPS FOR A NETWARE 6.5 GROUPWISE VOLUME SNAPSHOT COPY

NETAPP STORAGE PREPARATION
1. Enable SSH using NetApp FilerView® SecureAdmin™ on each NetApp storage that will host the
Novell LUN(s).
2. Create a new ROOT equivalent user on each NetApp storage. This step is performed from a
telnet session:
a. NTAP> Useradmin user add <name> -g administrators
3. From NetApp FilerView SecureAdmin:
a. SSH -> Configure -> Generate SSH keypair.
b. Enable SSH v2, Apply.
4. Generate SSH public and private keys (choose option A or B):
a. Generating keys using UNIX® ssh-keygen:
i. Ssh-keygen –t ras1 –b 1024
ii. For passphrase (leave empty for no passphrase)
b. Generating keys using Windows® puttygen:
i. Remove any text that is not part of the public key.
1
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ii. Before the first character of the public key, add ssh-rsa followed by a space.
c. Save SSH public key as “authorized_keys.”
d. Save SSH private key as “private.key.”
e. Set Options ssh.idle.timeout = 600.

PUTTYGEN EXAMPLE
The generated public key contains extra text and line breaks at the end of each line.
---- BEGIN SSH2 PUBLIC KEY ---Subject: john
Comment: "johndoe@netapp"
AAAAB3NzaC1yc2EAAAADAQABAAAAgQDJhJ6nk+2hm5iZnx737ZqxFgksPl3+OY1cP80s1amXuUrwB
p3/MUODEP5E51lzqjO0w5kyJlvPjCiLg9UqS7JeY5yd/6xyGarsde26De1ErbVJ1uqnxyAOlV9A1h
jBE8TbI+lyYBH+WezT0nySix6VBQTAWhv43r9lSudswYV80Q
==
---- END SSH2 PUBLIC KEY ---The following is the public key after removing text that is not part of the public key, removing line breaks
at the end of each line, and adding ssh-rsa at the beginning of the public key. If editing from Windows, do
not edit this file with notepad; use wordpad or textpad.
ssh-rsa
AAAAB3NzaC1yc2EAAAADAQABAAAAgQDJhJ6nk+2hm5iZnx737ZqxFgksPl3+OY1cP80s1amXuUrwB
p3/MUODEP5E51lzqjO0w5kyJlvPjCiLg9UqS7JeY5yd/6xyGarsde26De1ErbVJ1uqnxyAOlV9A1h
jBE8TbI+lyYBH+WezT0nySix6VBQTAWhv43r9lSudswYV80Q

5. Distribute SSH keys:
a. Public key goes on each NetApp storage in:
/etc/sshd/<username>/.ssh/authorized_keys.
Do this for a user other than administrator or root. Note: The directory structure may need
to be manually created.
b. If you are doing this from a Windows host, you will not be able to create the .ssh folder.
Instead, create /etc/sshd/username/ssh.
c. Copy the authorized_keys file into this directory; once copied use the mv command on
the NetApp storage to rename the ssh directory:
i. NTAP> priv set advanced
ii. NTAP> mv /etc/sshd/<username>/ssh /etc/sshd/<username>/.ssh
iii. NTAP> priv set
d. Private key goes on each NetWare server in SYS:\NetApp\private.key.
6. Confirm SSH commands can be run from each NetWare host. From the NetWare console, type:
NetWare> ssh -i sys:\NetApp\private.key <username>@<NetApp
storage> vol status
7.

On the NetWare server, create a sys:\system\ncf file for a scheduled backup. For this example
we will call the file GWSNAP.NCF for GroupWise Snapshot.
8.
Follow NetApp Data ONTAP® Administrative Guide to create:
a.
Flexible volume
b.
Disable scheduled NetApp scheduled Snapshot copies for this volume
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c.

Make sure either iSCSI or FCP is licensed, as well as SnapRestore® and
FlexClone®. You will also need both CIFS and NFS if you will be using VMware ESX with
NFS storage.
d.
Create an initiator group for either FCP or iSCSI.
e.
Create a NetWare LUN, associated with the previously created initiator group.
f.
Follow Novell’s guide to manage SAN storage over iSCSI or FCP or the VMware
guide for NFS storage.
g.
Install GroupWise on the NetWare NSS volume.
9.
In the GWSNAP.NCF file, point to the volume of which you wish to create a trustee Snapshot
copy; the trustee file will be saved on the same volume selected so that it will be included when
NetApp creates its Snapshot copy. For this example, we will use a volume called GWPO1.
10. From NoRM, once authenticated, select Manage Server, Schedule Tasks, create a new task:
a. Description: GroupWise 6am Snapshot copy
b. Console Command to Execute: sys:\system\gwsnap.ncf
c. Start Time: 6:00
d. Frequency: Daily

GWSNAP.NCF
This script will create a Snapshot copy, keeping seven, and rotating each Snapshot copy. It might be
adjusted to retain more or less.
trustee SAVE GWPO1: GWPO1:\GWTRUST.TXT
GWPO1:\grpwise\agent\gwtmstmp.nlm /p GWPO1:\grpwise\po /set
Ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap delete -V
GWPO1GWPO1.daily.7
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.6 GWPO1.daily.7
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.5 GWPO1.daily.6
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.4 GWPO1.daily.5
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.3 GWPO1.daily.4
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.2 GWPO1.daily.3
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap rename -V
GWPO1GWPO1.daily.1 GWPO1.daily.2
ssh –z -i sys:\netapp\private.key <user>@<NetApp storage> snap create -V
GWPO1GWPO1.daily.1

Note: The GroupWise Target Service Agent (GWTSA) automatically time stamps all backed-up user
databases (userxxx.db), so that the Allow Purge of Items Not Backed Up option can function to safeguard
users' deleted items against being purged from your GroupWise system before they have been backed
up.
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As the NetApp Snapshot procedure does not use the GWTSA, user databases must be manually time
stamped in order for the feature to work properly. Novell’s GroupWise Backup Time Stamp Utility
(GWTMSTMP) provides this functionality.
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STEPS TO RESTORE A NETWARE 6.5 VOLUME SNAPSHOT COPY
1. From the NetWare server, either from the NetWare console, NoRM, or Novell iManager, issue the
following two commands:
a. Unload the GroupWise application using the volume to be restored
b. Dismount <volume name you wish to restore>
c. NSS /PoolDeactivate=<pool name of volume you dismounted>
2. From a telnet session to the NetApp storage:
a. For iSCSI or Fibre connectivity:
i. NTAP> LUN show (to find the name of the LUN you wish to
restore)
ii. NTAP> lun offline /vol/<volume name>/<qtree name>/<LUN name>
b. NTAP> Snap list <Volume Name>
c. NTAP> Snap restore -t vol -s <Snapshot to restore> <volume name>
WARNING! This will revert the volume to a previous Snapshot copy.
All modifications to the volume after the Snapshot copy is created will be irrevocably lost.
Volume <volume name> will be made restricted briefly before coming back online.
Are you sure you want to do this? y
You have selected volume <volume>, <Snapshot>.
Proceed with revert? y
Volume <volume>: revert successful.
3. For iSCSI or Fibre connectivity: lun online /vol/<volume name>/<qtree
name>/<LUN name>
4. Reactivate the NetWare pool, remount the volume, then reload GroupWise.
a. NetWare> nss /poolactivate=<pool name>
b. NetWare> mount <volume name>
c. Reload GroupWise

RESTORE NETWARE FILE TRUSTEE INFORMATION
If restored to a different NetWare server, and you need file level trustee assignments restored, issue:
NetWare> TRUSTEE RESTORE <Volume>: <Volume>:\trustees.txt
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TO RESTORE INDIVIDUAL FILES RATHER THAN REPLACING A VOLUME

From a telnet session to the NetApp storage:
1. If connected over iSCSI or Fibre, issue:
NTAP> LUN show (to find the name of the LUN you wish to restore)
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2. Snap list <volume>
NTAP> Snap list <volume>
Using NetApp FlexClone to make a copy of a Snapshot copy
3. vol clone create (new volume name) –s file –b (current volume) (snap)
NTAP> vol clone create <new volume> –s file –b <current> GWPO1.daily.4
4. vol status –v (new volume name)
NTAP> vol status –v <new volume>

If you will be using the FlexClone volume for an extended period, you may wish to separate the
dependency from the parent Snapshot copy; otherwise, the Snapshot copy will remain in a “busy” state,
which prohibits it from being deleted with the GWSNAP.NCF script.
Optional step to separate volume from Snapshot dependency:
NTAP> vol clone split start (new volume name)
NTAP> vol clone split start <new volume name>
NTAP> vol clone split status <new volume name>
5. For block-based storage over iSCSI or Fibre, to mount the volume on a different server:
a. NTAP> lun show –m
b. NTAP> lununmap /vol/<volume>/<qtree>/<LUN>
c. lun map –f (volume) (initiator group) (lun ID)
NTAP> lun map –f /vol/<volume>/<qtree>/<LUN> <INITGRP> <ID>
d. NTAP> lun online /vol/<volume>/<qtree>/<LUN>
6. For NFS storage, which assumes you will be using a virtual software such as VMware ESX:
a. NFS listing type: exportfs
b. From VMware infrastructure client:
i. Choose Configuration -> Add storage
ii. Add virtual disk to the NetWare server that will be used for the restore, select to
use an existing disk when prompted.

Note:
1. On the NetApp storage, make sure that the initiator group has the NetWare server iSCSI qualified
name (iqn) entered. This is important so that the volume may be associated to the correct
NetWare server.
2. If you are restoring to the same server where the Snapshot copy was created, you will need to
rescan for devices; this can take up to 2 minutes for a refresh. NFS mountpoints presented to
VMware ESX cannot be restored to the same server where the Snapshot copy was created due
to volume signatures. This is not an issue with iSCSI or Fibre Channel connections.
3. If you are restoring to a different server than where the Snapshot copy was created:
a. For iSCSI or FCP:
i. NetWare> iscsinit disconnect xxx.xxx.xxx.xxx
ii. NetWare> iscsinit connect xxx.xxx.xxx.xxx
b. For iSCSI, FCP or VMware NFS:
i. NetWare> Load nssmu.nlm
ii. Select Devices, F2 to Scan.
iii. Select Pool, then rename (F6) pool to a new name.
iv. Select Volume, Activate Volume, then rename (F3) volume to a new name.
v. Mount volume.
vi. If you restored the volume on a different server, DO NOT import the NSS volume
object; instead, use ConsoleOne and add the object with a new name.
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Otherwise, NDS will attempt to use the former signature of the volume, replacing
the current NSS volume object.
4. For file-level restore outside GroupWise, remember to first issue the trustee restore command.
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RESTORING DELETED GROUPWISE MAILBOX ITEMS

SETTING UP A RESTORE AREA
1.
2.
3.
4.
5.

6.
7.
8.
9.
10.

From the client where you will be using ConsoleOne, map a drive letter to the restore volume.
In ConsoleOne, click Tools > GroupWise System Operations > Restore Area Management.
Click Create to set up a new restore area.
On the Identification tab, specify a unique name for the new restore area.
In the UNC Path field, browse to and select an existing directory that you want to use as a restore
area. This is where you would specify where the volume has been restored, i.e. \\nwserver\<NSS
volume>\PO.
Click Membership.
Click Add, select one or more post offices or users that need access to the new restore area, and
then click OK to add them to the membership list.
When the membership list is complete, click OK to create the new restore area.
Grant the POA Read, Write, and File Scan rights to the restore area.
If the restore area is located on a different server from where the post office directory is located,
provide the POA with a username and password for logging in to the remote server.
You can provide that information using the Remote User Name and Password fields on the Post
Office object’s Post Office Settings page, using the /user and /password startup switches, or
using the /dn startup switch.
If you want users to be able to retrieve individual items themselves, you can grant users Read,
Write, and File Scan rights to the restore area.

RESTORING A USER’S MAILBOX ITEMS
After you have set up a restore area and placed a backup copy of a post office into it, you can restore a
user’s mailbox items for the user.
1. In ConsoleOne, browse to and select a user object for which you need to restore mailbox items.
2. Click Tools > GroupWise Utilities > Backup/Restore Mailbox.
The Restore tab is automatically selected for you, with the restore area and directory location
displayed for verification.
3. Click Yes to restore the selected user’s mailbox items into his or her mailbox.
4. Notify the user and explain the following about the restored items:
o The user might want to manually delete unwanted restored items.
o The user should file or archive the items that he or she wants within seven days. After
seven days, unaccessed items are deleted after the amount of time allowed by existing
auto-delete settings. If auto-deletion is not enabled, the restored items remain in the
mailbox indefinitely.
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LETTING USERS RESTORE THEIR OWN MAILBOX ITEMS
After you have set up a restore area and given client users access to it, users can selectively restore
individual items into their mailboxes. This saves you the work of restoring mailbox items for users and it
also saves users the work of deleting unwanted restored items.
After a restore area has been set up:
1. In the GroupWise client, click File > Open Backup.
2. Browse to and select the restore area directory, then click OK.
3. In the Password field, type your GroupWise password, then click OK to access the backup copy
of your mailbox.
4. Retrieve individual items as needed.
The backup copy of your mailbox offers basic features such as Read, Search, and Undelete so
that you can locate and retrieve the items you need.
5. When you are finished restoring items to your live mailbox, click File > Open Backup again to
remove the check mark from the Open Backup option and return to your live mailbox.
WHEN COMPLETED WITH THE MAILBOX RESTORE
From NetWare:
1. Remove the GroupWise Restore area.
2. Delete volume object.
3. For NFS storage on VMware ESX:
1. Shut NetWare server down; the restored volume cannot be removed until the NetWare
server has been brought off-line.
2. From VMware IC, remove NetWare virtual disk.
3. From VMware IC, remove NFS storage disk.
4. Restart the NetWare server.
4. For block-level storage:
1. Dismount the volume (dismount <restored volume>)
2. Dismount the pool (nss /pooldeactivate=<restored volume>)

From the NetApp storage:
1. lun offline /vol/<volume>/<qtree>/<LUN> (only for block based storage)
2. vol offline /vol/<restored volume>
3. vol destroy /vol/<restored volume>

USEFUL GROUPWISE SCRIPTS
They are presented as an example and require modifying the path and names used to your specific
environment.
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GWSTRT.NCF (FOR GROUPWISE 7)
load address space=ntapmta GWNTAP:\AGENT\GWMTA @CA.MTAprotection restart ntapmta
load address space=ntappoa GWNTAP:\AGENT\GWPOA @SF.POA
protection restart ntapoa
?GWNTAP:\gwia\gwia @gwia.cfg
?GWNTAP:Web\gwinter @WEBAC70A.waa

GWSTOP.NCF
unload gwinter
unload gwia
unload address space=ntappoa
unload address space=ntapmta
delay 10
unload kill address space=ntappoa
unload kill address space=ntapmta
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CONCLUSION

Although there are various methods for creating a NetApp backup while making sure the data is
quiesced, the method outlined in this document uses NetWare’s Snapshot technology to make
sure a copy of a file is made before allowing a user or an application to commit changes, rather
than working with the application to quiesce the data. This provides Novell’s guarantee of a valid
restore point in the event of data corruption.
By combining the execution of the NetWare trustee utility before creation of each NetApp
Snapshot copy, a volume may be restored to any server within the Novell eDirectory tree, while
preserving Novell’s Directory Services (NDS) rights.
This document does not cover using Novell’s Pool Freeze/Thaw APIs. The Pool Freeze/Thaw
method quiesces the NSS Pool and is therefore unaware of what an application may be doing. As
a result, applications which may have a high file throughout in a small window—for example,
antivirus scanning software and databases—may exceed the Pool Freeze buffer during a
Snapshot window. This can leave GroupWise in an unknown state when a restore is performed,
resulting in GroupWise needing to rebuild its index, and finding messages that were in flight being
flagged as orphans or objects unknown. The NetWare NSS Volume File-Level Snapshot copy
safeguards against this by making sure each time a file is opened, a copy is made, and the copy
is not deleted until the file is closed.
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