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What Performance Advisor is
Performance Advisor is a Java-based client application that runs in the NetApp Management Console
and allows you to view comprehensive performance information about storage objects in your
environment.
You can use the performance data to perform the following:
•
•
•

Monitor storage objects for usage levels and optimal functioning, by viewing the data for all the
monitored devices discovered by the DataFabric Manager server.
Identify potential issues in the data infrastructure.
Perform short-term trend analysis for the data infrastructure.

Topology of Performance Advisor
The topology of Performance Advisor is designed specifically to help you gather performance data.

Performance Advisor topology
The Performance Advisor topology includes the NetApp Management Console (which provides the
interface to Performance Advisor), the DataFabric Manager server (which includes a performancemonitoring server), and one or more storage systems, vFiler units, clusters or Vservers.
Elements in the Performance Advisor interact in the following ways:
•

•

The performance-monitoring server collects and stores performance data from one or more
storage systems or vFiler units on the network. The monitoring server is installed and enabled by
default as part of the DataFabric Manager server installation.
Performance Advisor reads the performance data stored on the monitoring server and generates
performance-related views and charts. You must install the NetApp Management Console on a
separate host (Windows or Linux system) to manage the performance-monitoring server and view
performance data.
Note: Performance Advisor is available only on the host on which the NetApp Management
Console is installed. You cannot view Performance Advisor remotely through a browser.

•

The DataFabric Manager server monitors one or more storage nodes, Vservers, storage systems
or vFiler units.
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Limitations of Performance Advisor (7-Mode environments only)
Performance Advisor does not collect real-time data for any view that includes a bar graph to
minimize CPU utilization.
Although the performance-monitoring server supports simultaneous connections from multiple
Performance Advisor instances, connection from many instances of Performance Advisor
simultaneously can result in slower collection of data.

Authentication to access Performance Advisor
The NetApp Management Console platform in which Performance Advisor runs must supply valid
user name and password credentials to connect with the performance-monitoring server. The server
obtains the user name and the password from the database on the workstation, and validates the
credentials with the HTTP or HTTPS authentication mechanisms.
HTTP is the default protocol in 7-Mode environments and HTTPS is the default protocol in clustered
environments.

Performance Advisor support for hierarchical groups
Performance Advisor supports hierarchical groups created on the DataFabric Manager server 3.3 or
later, including groups with or without storage objects, groups containing direct storage groups,
groups containing subgroups, and the global group.
A group can be one of the following:
•
•
•
•
•

An empty group with no storage objects or subgroups
A group containing storage objects only, with no subgroups
A group containing subgroups only, without direct storage objects
A group containing one or more direct storage objects and one or more subgroups
The global group
The properties and configurations of this group are applied by default to all of its subgroups.

All the operations that you can perform on the global group are valid for the subgroups too. For
example, you can click a subgroup folder to display the Summary View window.

Performance Advisor support for secure connections
Performance Advisor supports HTTP, SSL and HTTPS connections for the performance-monitoring
server, Performance Advisor, and the monitored storage systems, clusters, Vservers, and vFiler hosts.
The DataFabric Manager server generates an SSL certificate for the performance-monitoring server
automatically at startup. You do not have to take any action to generate the certificate.
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Note: If you use HTTPS transport for the connection between the performance-monitoring server
and the storage system or vFiler host, it might adversely affect the performance of the storage
system. In such cases, you should use HTTP transport only.

Administrator roles in Performance Advisor
You can use administrator roles such as the GlobalRead, GlobalWrite, GlobalDelete, and
GlobalPerfManagement roles to control access to performance data in the DataFabric Manager
server.
The administrator roles determine the availability of menu options in Performance Advisor. If the
options appear dimmed in the application interface, it indicates that the options are unavailable to
you for the selected storage system or vFiler unit.
The following roles help you to work with performance views in the interface:
•
•
•

The GlobalRead role allows you to view all the performance views.
The GlobalWrite and GlobalDelete roles allow you to create, edit, and delete custom views within
any group.
The GlobalPerfManagement role allows you to manage views, event thresholds, and alarms, apart
from viewing performance information in the application.
You can use this role to work with custom views.

Performance Advisor support for vFiler units (7-Mode
environments only)
Performance Advisor supports the MultiStore feature in DataFabric Manager server 3.3 or later. You
can view performance data for the objects in a vFiler unit, such as LUNs, volumes, and qtrees. You
can also view physical performance data about the hosting storage system, such as CPU usage.
The vFiler unit counters are displayed for the hosting storage systems running Data ONTAP 7.1 or
later.
Note: The vFiler unit, All report in Operations Manager console lists your network’s vFiler units
and their hosting storage systems.

See the OnCommand Unified Manager Operations Manager Administration Guide for information
about the DataFabric Manager server support for vFiler units.
Related information

OnCommand Unified Manager Operations Manager Administration Guide: support.netapp.com/
documentation/productsatoz/index.html
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Understanding information relevant to 7-Mode
and clustered environments
Because OnCommand Unified Manager supports both clustered Data ONTAP and 7-Mode
environments, it is important to identify the information that is relevant to you.
The following labeling guidelines can help you to better understand the content that is provided in
the OnCommand Unified Manager documentation:
•

•

•

•

(7-Mode environments only)
Topic titles or information within a topic include this label when the topic or information is
applicable to 7-Mode environments only. For example, the title Adding storage systems (7-Mode
environments only) indicates that this task is relevant for 7-Mode environments only.
(clustered environments only)
Topic titles or information within a topic include this label when the topic or information is
applicable to the clustered environment only. For example, the title Adding clusters (clustered
environments only) indicates that this task is relevant for the clustered environment only.
No mode labels in titles
Topics that apply to both 7-Mode and clustered environments do not include any labels in the
title. For example, the topic Creating alarms for events provides information that is relevant to
both 7-Mode and clustered environments.
No mode labels in topic information
Information within a topic that applies to both 7-Mode and clustered environments does not
include any labels.

The documentation includes the following topics to help you navigate to the specific information that
you want:
•
•

Each section in the Help includes two topics that provide links to information in that section of
the Help, which is relevant to each mode.
Each product manual includes two topics that provide links to information throughout the manual,
which is relevant to each mode.

7-Mode environments: List of Performance Advisor tasks
and information
Because Unified Manager supports both clustered and 7-Mode environments, it is important to
identify the information that relates to your 7-Mode environment.
The following list provides links to all the administration tasks and information related to storage in a
7-Mode environment:
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Performance Advisor
•
•
•
•
•
•
•
•
•

What Performance Advisor is on page 8
Topology of Performance Advisor on page 8
Performance Advisor topology on page 8
Limitations of Performance Advisor on page 9
Authentication of a Performance Advisor instance on page 9
Performance Advisor support for hierarchical groups on page 9
Performance Advisor support for secure connections on page 9
Administrator roles in Performance Advisor on page 10
Performance Advisor support for vFiler units on page 10

About NetApp Management Console
•
•
•
•
•
•

About NetApp Management Console on page 20
What NetApp Management Console is on page 20
Applications and capabilities supported by the NetApp Management Console on page 20
NetApp Management Console window layout and navigation on page 21
NetApp Management Console window customization on page 22
NetApp Management Console data filtering on page 23

Performance objects and counters
•
•
•
•
•
•

Performance objects and counters on page 25
What performance objects are on page 25
List of performance objects on page 25
What a performance counter is on page 27
Definitions of performance counters on page 28
List of CLI commands on page 49

Access permissions for Role Based Access Control
•
•
•
•
•
•
•

What access permission is on page 52
RBAC for configuring views on page 52
RBAC for modifying storage system settings on page 52
RBAC for setting thresholds on page 53
RBAC for threshold templates on page 55
RBAC for configuring events on page 56
RBAC for configuring alarms on page 56

Performance Advisor setup
•
•

Performance Advisor and server setup requirements on page 58
Enabling the performance-monitoring server on page 58
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•
•
•

Setting up transport between the performance-monitoring server and Performance Advisor on
page 58
Setting up transport protocols between Performance Advisor and monitored devices on page 60
Setting up appliance-level transport between Performance Advisor and monitored devices on
page 59

Performance Advisor user interface
•
•
•
•
•
•
•
•

Getting started with the Performance Advisor user interface on page 61
Starting Performance Advisor on page 61
Disconnecting from Performance Advisor on page 61
Storage objects unavailable in Performance Advisor on page 61
Unavailable menu options in the Performance Advisor interface on page 62
Zero-value data in a Performance Advisor chart on page 62
Absence of data in a Performance Advisor chart on page 62
Display of new storage systems in Performance Advisor on page 63

Dashboard and events
•
•
•
•
•
•
•

Overview of the NetApp Management Console dashboard on page 64
Dashboard panel descriptions on page 64
What events are on page 65
How to know when an event occurs on page 65
Monitoring events on page 66
Responding to and acknowledging events on page 67
Deleting events on page 67

Views
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Views in Performance Advisor on page 69
What the performance view window is on page 69
What default views are on page 69
What custom views are on page 69
What advanced views are on page 70
Types of data in Performance Advisor on page 71
Logical and physical objects hierarchy on page 71
Analyzing historical data on page 71
What synchronizing time axes is on page 72
Viewing performance data on page 72
Displaying tabbed views on page 72
Selecting a performance view on page 73
Closing a performance view on page 73
Actions you can perform in the performance views on page 73
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•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Viewing the time period in a chart on page 74
Resetting both axes on page 74
Synchronizing time axes on page 74
Undoing synchronization of time axes on page 75
How to use the legend for predefined views and custom views on page 75
How to view thresholds on page 75
Creating advanced views on page 75
Adding thresholds using a view on page 76
Changing the chart type on page 76
Playing or pausing data collection on page 76
Printing a chart from a view on page 77
Enabling charts to scale the y axis on page 77
Diagnosing a performance issue on page 77
Performance monitoring with custom views on page 78
When must you create a custom view on page 78
How data from counters is displayed on page 78
Viewing data on page 78
Creating a custom view on page 79
Opening a custom view on page 79
Editing custom views on page 80
Deleting a custom view on page 80
CPU utilization issues on storage systems or vFiler hosts on page 81
Analysis of real-time data on page 81
Methods for saving performance data on page 81
Saving a chart on page 81
Exporting a view to a .csv file on page 82
Predefined views of logical and physical objects on page 82
Predefined views at the global or group level on page 83
Predefined views at the storage system level on page 85
Predefined views at the vFiler unit level on page 90
Predefined views at the processor level on page 91
Predefined views at the network interface level on page 91
Predefined views at the dataset level on page 92
Predefined views at the resource pool level on page 92
Predefined views at the volume level on page 93
Predefined views at the qtree level on page 95
Predefined views at the LUN level on page 96
Predefined views at the aggregate level on page 97
Predefined views at the disk level on page 97
Predefined view at the target level on page 98
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Alarms, Storage systems, and Thresholds
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Alarms, hosts, and thresholds on page 104
What alarms are on page 104
List of alarm management tasks on page 104
Overview of alarm management tasks on page 105
Monitoring alarms on page 105
Creating alarms on page 106
Editing alarms on page 106
Testing alarms on page 107
Enabling or disabling alarms on page 107
Adding alarms on page 108
Deleting alarms on page 109
Responding to alarms on page 109
How hosts become visible to Performance Advisor on page 110
Host table field descriptions on page 110
Editing host credentials on page 111
Configuration of data collection on page 112
Copying the data collection configuration on page 112
Effect of increasing sample rates on page 112
Setting retention periods and sample rates on page 113
How thresholds work on page 113
What resource properties are on page 114
Viewing threshold values on page 114
When to use thresholds in combination on page 115
What the Details tab is on page 115
Adding thresholds on page 115
Editing thresholds by using the Summary tab on page 115
Editing thresholds using charts on page 116
Editing thresholds using the Details tab on page 116
Deleting thresholds on page 117
What a threshold template is on page 117

Clustered environments: List of Performance Advisor tasks
and information
Because Unified Manager supports both clustered and 7-Mode environments, it is important to
identify the information that relates to your 7-Mode environment.
The following list provides links to all the administration tasks and information related to storage in a
clustered environment:
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Performance Advisor
•
•
•
•
•
•
•

What Performance Advisor is on page 8
Topology of Performance Advisor on page 8
Performance Advisor topology on page 8
Authentication of a Performance Advisor instance on page 9
Performance Advisor support for hierarchical groups on page 9
Performance Advisor support for secure connections on page 9
Administrator roles in Performance Advisor on page 10

About NetApp Management Console
•
•
•
•
•
•

About NetApp Management Console on page 20
What NetApp Management Console is on page 20
Applications and capabilities supported by the NetApp Management Console on page 20
NetApp Management Console window layout and navigation on page 21
NetApp Management Console window customization on page 22
NetApp Management Console data filtering on page 23

Performance objects and counters
•
•
•
•
•
•

Performance objects and counters on page 25
What performance objects are on page 25
List of performance objects on page 26
What a performance counter is on page 27
Definitions of performance counters on page 28
List of CLI commands on page 49

Access permissions for Role Based Access Control
•
•

What access permission is on page 52
RBAC for setting thresholds on page 53

Performance Advisor setup
•
•
•
•
•

Performance Advisor and server setup requirements on page 58
Enabling the performance-monitoring server on page 58
Setting up transport between the performance-monitoring server and Performance Advisor on
page 58
Setting up transport protocols between Performance Advisor and monitored devices on page 60
Setting up appliance-level transport between Performance Advisor and monitored devices on
page 59
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Performance Advisor user interface
•
•
•
•
•
•
•
•

Getting started with the Performance Advisor user interface on page 61
Starting Performance Advisor on page 61
Disconnecting from Performance Advisor on page 61
Storage objects unavailable in Performance Advisor on page 61
Unavailable menu options in the Performance Advisor interface on page 62
Zero-value data in a Performance Advisor chart on page 62
Absence of data in a Performance Advisor chart on page 62
Display of new storage systems in Performance Advisor on page 63

Dashboard and events
•
•
•
•
•
•
•

Overview of the NetApp Management Console dashboard on page 64
Dashboard panel descriptions on page 64
What events are on page 65
How to know when an event occurs on page 65
Monitoring events on page 66
Responding to and acknowledging events on page 67
Deleting events on page 67

Views
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Views in Performance Advisor on page 69
What the performance view window is on page 69
What advanced views are on page 70
Types of data in Performance Advisor on page 71
Logical and physical objects hierarchy on page 71
Analyzing historical data on page 71
What synchronizing time axes is on page 72
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Closing a performance view on page 73
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How to use the legend for predefined views and custom views on page 75
How to view thresholds on page 75
Creating advanced views on page 75
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•
•
•
•
•
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•
•
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•
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About NetApp Management Console
NetApp Management Console is used by administrators to complete management tasks aided by the
DataFabric Manager server, but it runs on a Windows or Linux system separate from the server on
which the DataFabric Manager server is installed.
NetApp Management Console enables storage, application, and server administrators to perform
management tasks such as data backup protection, space management, resource provisioning, data
migration, and performance tuning, without having to switch between separate user interfaces.
The DataFabric Manager server provides infrastructure services (such as discovery, monitoring, rolebased access control (RBAC), auditing, and logging for products in the storage and data suites) for
NetApp Manageability Software client consoles. The DataFabric Manager server software runs on a
separate server and is managed through the Operations Manager console, the Web-based user
interface of the DataFabric Manager server. For more information about the DataFabric Manager
server and Operations Manager console, see the Operations Manager Administration Guide.
Related information

Documentation on the NetApp Support Site: support.netapp.com

What NetApp Management Console is
NetApp Management Console is a client platform that supports NetApp Manageability Software
capabilities. Together, NetApp Management Console and the associated OnCommand Unified
Manager console, enable you to implement both policy-based and on-demand protection,
provisioning, migration, and restoration of data contained in your physical and virtual storage
systems.

Applications and capabilities supported by the NetApp
Management Console
The NetApp Management Console supports Performance Advisor, data protection capability, and
provisioning capability.
Performance
Advisor

This application provides a single location from which you can view
comprehensive information about the performance of storage systems, vFiler
units, storage nodes and Vservers, and perform short-trend analysis. The
application also helps you identify the data infrastructure causes and potential
causes of reduced performance.
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The NetApp
Management
Console data
protection
capability

The NetApp Management Console data protection capability provides a policybased management tool to help you unify and automate backup and mirroring
operations. This capability uses a holistic approach to data protection. It
provides end-to-end, workflow-based design and seamless integration of
SnapVault, SnapMirror, and Open Systems SnapVault to enable you to manage
large-scale deployments easily.
The disaster recovery feature of the NetApp Management Console data
protection capability enhances your data protection services by enabling you to
continue to provide data access to your users, even in the event of mishap or
disaster that disables or destroys the storage systems and V-Series systems in
your primary data node. You can quickly enable your secondary storage
systems to provide primary data storage access to your users with little or no
interruption, until your primary storage systems are reenabled or replaced.

The NetApp
Management
Console
provisioning
capability

The NetApp Management Console provisioning capability helps you simplify
and automate the tasks of provisioning and managing storage. It provides
policy-based provisioning and conformance of storage in datasets. This
capability also enables you to manually add volumes or qtrees to a dataset at
any time, provides manual controls for space and capacity management of
existing storage and newly provisioned storage, and enables you to migrate
datasets and vFiler units to a new storage destination.
The deduplication feature of the NetApp Management Console provisioning
capability enhances your data provisioning services by enabling you to
eliminate duplicate data blocks to reduce the amount of storage space used to
store active data.

NetApp Management Console window layout and navigation
You can use NetApp Management Console to navigate between capabilities, to display Help, and to
log out of the console.
Learning about the
NetApp Management
Console data
protection capability

The Get Started section of the user interface provides an overview of the
NetApp Management Console data protection capability, a short tutorial
that demonstrates how to set up protection, and a list of frequently asked
questions (FAQs).

Learning about
disaster recovery

The Get Started section of the user interface provides an overview of
disaster recovery, a short tutorial that demonstrates how to set up disaster
recovery, and a list of frequently asked questions (FAQs).

Learning about the
NetApp Management
Console provisioning
capability

The Get Started section of the user interface provides an overview of the
NetApp Management Console provisioning capability, a short tutorial that
demonstrates how to set up provisioning, and a list of frequently asked
questions (FAQs).
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Moving back and
forth between panes

The Back and Forward arrow buttons helps you toggle between your last
and previous panes.

Toggling between
capabilities

•

•

To use the NetApp Management Console data protection capability or
the NetApp Management Console provisioning capability, select Tasks
> Manage Data or go to the Tasks Bar and click
.
To use Performance Advisor, select Tasks > Manage Performance or
go to the Tasks Bar and click

Displaying help

•
•

.

To display the Help for all applications and capabilities on NetApp
Management Console, click Help > Help Contents.
To display Help for the specific window that is currently displayed,
click Help > Help For This View or click

.

Logging out

•
•

Viewing product
license information

To view information about the product licenses you have installed, click
Help > About > Licenses. Removed or added licenses are reflected in the
license list after you restart NetApp Management Console.

To log out, select File > Log Out or click the logout button.
To log out and close NetApp Management Console, select File > Exit.

Capabilities that run in NetApp Management Console vary in their window layout. However, the
windows are generally divided into two panes:
•
•

Use the menu bar on the left to move within NetApp Management Console.
Use the content pane on the right to view and manage data.
The content pane is generally divided into two areas: lists of selectable data and details of the
selected data. Click

, when it is displayed, for additional details.

Note: Some applications or capabilities might have additional navigation features not described in

this section. In addition, software version incompatibility might result in some reduced
functionality, which might cause some menu options or buttons to be disabled.

NetApp Management Console window customization
NetApp Management Console includes features that you can use to customize the console window
layout. By customizing the console windows, you can control which data is viewable or how it is
displayed.
Note: You cannot perform all the following customizing tasks for every window.
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Hiding or
redisplaying the
Tasks Bar

You can hide the Tasks Bar to increase the space available for the content
pane. (The overall width of the window remains the same when the bar is
hidden.) You use the View menu to hide or display the bar.

Selecting columns
to display

In content panes that include a list divided into columns, you can choose
which columns you want to display. To display or hide a column, you can
click the column-selection icon in the upper-right corner above the scroll bar
( ), and then click the name of a column heading from the selection list.
Columns that are already displayed are identified with a check mark.
Note: The default version of a list does not necessarily include all the
available columns. You might find additional columns available in the
column selection list.

Readjusting column In content panes that include a list divided into columns, you can adjust the
width of individual columns by horizontally dragging the vertical line
widths
between the column headings. If accommodating all the columns you want
to include results in column widths that obscure data, you can still see the
entire value of a column field by placing your cursor over the field. A tool
tip opens, displaying the entire value of the field. You can maximize data
visibility across all the columns by clicking the column selection icon (
and selecting Pack All Columns.

)

Rearranging the
column order

In content panes that include a list divided into columns, you can rearrange
the column order for a session by dragging and dropping column headings
horizontally within the table. The arrangement persists until you exit the
console.

Reapportioning a
content pane

A splitter bar divides a content pane list area from the details area. You can
move the splitter bar to increase or decrease the proportion of the content
pane that displays the list of selectable data.

NetApp Management Console data filtering
You can use the data filtering features to display only data meeting the criteria you specify.
In large-scale environments, the content pane might list so much data that it becomes difficult to
locate the information you want. Filtering the data by specified criteria helps you focus on the issues
most important to you.
Note: Not all filtering features are available for every window.

Filtering by
group

The Group selection list in the toolbar enables you to display only the data that
pertains to objects in a selected group. This setting persists until you log out or
choose a different group.
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Filtering by
regular
expression

You can filter columns displaying site-specific values, such as storage system
names or dataset names, by regular expression. To filter a column by regular
expression, click the filter icon in the column heading ( ) and specify the
regular expression to match against values in the column field. Headings of
filtered columns are highlighted to remind you that some data is not currently
displayed.
NetApp Management Console uses Java regular expression syntax for filtering
data, for example:
•
•

•
Filtering by
column values

Filtering by
column view
Sorting by
column values

To view only items beginning with the letters "sch," type sch in the filter
field, which matches Schedule but not SnapMirror.
To view only items containing "space" somewhere in their string,
type .*space in the filter field, which matches strings such as Volume Space
Normal.
To view only items ending with the string "ok," type *ok in the filter field,
which matches strings such as SnapMirror: Date Ok.

When a column displays a set of predefined possible values, you can choose to
display only the rows of data that include a selected value. To filter a column by a
specific, predefined value, click the filter icon in the column heading ( ) and
select one or more of the predefined values from the drop-down list. Headings of
filtered columns are highlighted to remind you that some data is not currently
displayed. Click "All" to select or clear all the values.
You can click
in the upper-right corner of the list to select the columns you
want displayed.
You can click the column header to change the sort order of the column entries.
When you click the column header, the sort arrow appears for that column.
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Performance objects and counters
You can monitor the performance of storage systems by understanding performance objects and
counters in Performance Advisor.

What performance objects are
Performance objects are collections of counters for specific subsystem types.
The names of the objects correspond to the subsystem names that are displayed in the navigation
pane of Performance Advisor.

List of performance objects (7-Mode environments only)
You should be aware of the performance objects that you monitor as part of storage administration in
7-Mode systems.
Performance Advisor displays a default performance view for every performance object listed in the
following tables, except for qtrees.
Note: In the following table, performance objects that apply to both storage system and vFiler
units are noted in parentheses. All other listed performance objects apply to storage system only.

The following performance objects are available for monitoring storage objects running Data
ONTAP 8.0 (or later):
Object name

Type of data contained

aggregate

Aggregate statistics (includes aggregates containing
traditional volumes)

cifs

CIFS statistics for systems with a CIFS license

disk

Disk statistics (per disk)

fcp

FCP statistics for systems with an FCP license

ifnet

Statistics on various network interface cards in the system
Note: It is possible that a system can have all target cards
and no interface cards.

iscsi

iSCSI statistics for systems with an iSCSI license

LUN (applies to vFiler units also)

LUN statistics (per LUN)

nfsv3

NFS statistics for systems with an NFS license
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Object name

Type of data contained

nfsv4

NFS statistics for systems with an NFS license

processor

Processor statistics (per processor)

qtree (applies to vFiler units also)

Qtree statistics (per qtree)
Note: To minimize negative performance impact on
storage systems that it monitors, Performance Advisor
does not automatically generate default performance views
for its qtree performance objects; however, you can use the
application to define performance views for individual
qtrees.

system

Summary of the general performance health status of the
system

target

Statistics on the target cards in the system

vFiler units (applies to vFiler units
and their hosting storage systems)

Statistics that apply to vFiler units and their hosting storage
systems

volume (applies to vFiler units also) Volume statistics (per volume)

List of performance objects (clustered environments only)
You should be aware of the performance objects that you monitor when managing clusters.
Performance Advisor displays a default performance view for every performance object that is listed
in the following tables, except for qtrees.
The following performance objects are available for monitoring storage objects running Data
ONTAP 8.0 or later:
Object name

Type of data contained

system

Summary of the general performance health status of the
system

nfsv3

NFS statistics for systems with an NFS license

cifs:node

CIFS statistics for systems with a CIFS license, at the node
level

cifs:vserver

CIFS statistics for systems with a CIFS license, at the
Vserver level

fcp_lif:node

FCP statistics for systems with an FCP license, at the node
level
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Object name

Type of data contained

fcp_lif:vserver

FCP statistics for systems with an FCP license, at the Vserver
level

iscsi_lif:vserver

iSCSI statistics for systems with an iSCSI license, at the
Vserver level

LUN

LUN statistics (per LUN)

processor

Processor statistics (per processor)

ifnet

Statistics on the network interface cards in the system

aggregate

Aggregate statistics

volume

Volume statistics (per volume)

volume:vserver

Volume statistics, at the Vserver level

volume:node

Volume statistics, at the node level

disk

Disk statistics (per disk)

What a performance counter is
A performance counter is the statistical measurement of activity on a storage object or a storage
subsystem. The DataFabric Manager server collects data from the monitored storage object, and
Performance Advisor uses this data to generate a performance chart or part of a performance chart.
For example, Performance Advisor might use the volume's total_ops counter of a storage system to
generate a chart that displays total operations-per-second on that volume on a minute-to-minute
basis.
The server collects data for a counter from the time the counter is added to a view. When the view is
deleted, data collection for the counter stops. When you add a counter to a view, data collection
begins with the counter in that view.
Note: Each type of storage object or subsystem has a set of counters. However, a particular storage
object might not have non-zero data for all the counters available to it.

For example, every storage system has an http_ops counter. However, if HTTP is not enabled on
the storage system, the counter contains only zero-value data. If SnapMirror is not licensed on the
storage system, the counters for the SnapMirror statistics do not contain any data.
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Definitions of performance counters
You must be aware of the performance counters in Performance Advisor that enable you to collect
data for each performance object.
The availability of the counters and their descriptions might vary depending on the version of Data
ONTAP running on the storage system.
Aggregate object
Counter name

Description

Unit

total_transfers

Total number of disk operations
serviced by the aggregate

per sec

user_reads

Number of user read operations
performed by the aggregate

per sec

user_writes

Number of user write operations
performed by the aggregate

per sec

cp_reads

Number of read operations to the
aggregate during consistency-point
processing

per sec

user_read_blocks

Number of blocks transferred for
user read operations

per sec

user_write_blocks

Number of blocks transferred for
user write operations

per sec

cp_read_blocks

Number of blocks transferred for
consistency-point read operations

per sec

cifs object (7-Mode environments only)
Counter name

Description

Unit

cifs_latency

Average latency for CIFS
operations

millisec

cifs_ops

Total number of CIFS
operations

per sec
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cifs:node object (clustered environments only)
Counter name

Description

Unit

cifs_latency

Aggregated CIFS latency
at the node level

microsec

cifs_ops

Aggregated CIFS
operations at the node
level

per sec

cifs:vserver object (clustered environments only)
Counter name

Description

Unit

cifs_latency

Aggregated CIFS latency at the microsec
Vserver level

cifs_ops

Aggregated CIFS operations at
the Vserver level

per sec

Counter name

Description

Unit

total_transfers

Total number of disk operations per sec
performed by the aggregate

user_reads

Number of user read operations per sec
performed by the aggregate

user_writes

Number of user write
operations performed by the
aggregate

per sec

cp_reads

Number of read operations to
the aggregate during
consistency point processing

per sec

guaranteed_reads

Number of disk read operations per sec
initiated each second for RAID
reconstruction or scrubbing
activities

guaranteed_writes

Number of write operations
initiated each second for RAID
reconstruction or scrubbing
activities

disk object

per sec
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Counter name

Description

Unit

user_read_chain

Average number of blocks
transferred in each user read
operation

NA

user_write_chain

Average number of blocks
transferred in each user write
operation

NA

cp_read_chain

Average number of blocks
NA
transferred in each consistencypoint read operation during a
consistency point

disk_busy

Time since the last outstanding
request to the disk

percent

user_read_blocks

Number of blocks transferred
for user read operations

per sec

user_write_blocks

Number of blocks transferred
for user write operations

per sec

cp_read_blocks

Number of blocks transferred
for consistency-point read
operations

per sec

user_read_latency

Average latency per block, in
microseconds, for user read
operations

microsec

user_write_latency

Average latency per block, in
microseconds, for user write
operations

microsec

cp_read_latency

Average latency per block, in
microseconds, for consistencypoint read operations

microsec

disk object (7-Mode environments only)
Counter name

Description

Unit

throughput

Disk KB read and written

per sec
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fcp object (7-Mode environments only)
Counter name

Description

Unit

fcp_ops

FCP operations per second

per sec

fcp_write_data

FCP bytes written per second

b per sec

fcp_read_data

FCP bytes read per second

b per sec

fcp_read_latency

Average latency of read
operations for all the LUNs in
the system accessed over FCP

millisec

fcp_read_ops

Total number of read
operations for all the LUNs in
the system accessed over FCP

per sec

fcp_write_latency

Average latency of write
operations for all the LUNs in
the system accessed over FCP

millisec

fcp_write_ops

Total number of write
operations for all the LUNs in
the system accessed over FCP

per sec

fcp_throughput

Total FCP data sent and
received by the system

b per sec

fcp_lif:node object (clustered environments only)
Counter name

Description

Unit

read_ops

Aggregated FCP read
operations at the node level

per sec

write_ops

Aggregated FCP write
operations at the node level

per sec

other_ops

Other FCP operations at the
node level

per sec

read_data

Aggregated read data at the
node level

b per sec

write_data

Aggregated write data at the
node level

b per sec
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fcp_lif:vserver object (clustered environments only)
Counter name

Description

Unit

read_ops

Aggregated FCP read
operations at the Vserver level

per sec

write_ops

Aggregated FCP write
operations at the Vserver level

per sec

other_ops

Other FCP operations at the
Vserver level

per sec

read_data

Aggregated read data at the
Vserver level

b per sec

write_data

Aggregated write data at the
Vserver level

b per sec

Counter name

Description

Unit

recv_packets

Packets received per second

per sec

recv_errors

Errors per second while
receiving packets

per sec

send_packets

Packets sent per second

per sec

send_errors

Errors per second while
sending packets

per sec

collisions

Collisions per second on
CSMA interfaces

per sec

recv_data

Total bytes received per second b per sec

send_data

Total bytes sent per second

b per sec

recv_mcasts

Packets received per second
through multicast

per sec

send_mcasts

Packets sent per second through per sec
multicast

total_data

Total data sent and received
over the interface

b per sec

total_errors

Total data sent and received
over the interface

per sec

ifnet object

Performance objects and counters | 33
Counter name

Description

Unit

total_mcasts

Total number of errors while
receiving and sending over the
interface

per sec

total_packets

Total packets sent and received
through multicast

per sec

iSCSI object (7-Mode environments only)
Counter name

Description

Unit

iscsi_ops

iSCSI operations per second

per sec

iscsi_write_data

iSCSI bytes written per second

b per sec

iscsi_read_data

iSCSI bytes read per second

b per sec

iscsi_read_latency

Average latency of read
millisec
operations for all the LUNs in
the system accessed over iSCSI

iscsi_read_ops

Total number of read
per sec
operations for all the LUNs in
the system accessed over iSCSI

iscsi_write_latency

Average latency of write
millisec
operations for all the LUNs in
the system accessed over iSCSI

iscsi_write_ops

Total number of write
per sec
operations for all the LUNs in
the system accessed over iSCSI

iscsi_throughput

Total FCP data sent and
received by the system

b per sec

iscsi_lif:vserver object (clustered environments only)
Counter name

Description

iscsi_read_ops

Aggregated total number of
per sec
read operations for all the
LUNs in the system accessed
over iSCSI, at the Vserver level

Unit
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Counter name

Description

Unit

iscsi_write_ops

Aggregated total number of
per sec
write operations for all the
LUNs in the system accessed
over iSCSI, at the Vserver level

LUN object
Counter name

Description

Unit

read_ops

Read operations per second

per sec

write_ops

Write operations per second

per sec

other_ops

Other operations per second

per sec

read_data

Read bytes per second

b per sec

write_data

Write bytes per second

b per sec

total_ops

Total number of operations on
the LUN

per sec

avg_latency

Average latency for all
operations on the LUN

millisec

read_align_histo

Histogram of WAFL read
alignment

percent

read_partial_blocks

Percentage of reads whose size
is not a multiple of the WAFL
block size

percent

throughput

Total data sent and received by
the LUN

b per sec

unaligned_reads

Percentage of WAFL unaligned percent
read operations

unaligned_writes

Percentage of WAFL unaligned percent
write operations

write_align_histo

Histogram of WAFL write
alignment

percent

write_partial_blocks

Percentage of write whose size
is not a multiple of the WAFL
block size

percent
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nfsv3 object
Counter name

Description

Unit

nfsv3_ops

Total number of NFSv3
operations

per sec

nfsv3_read_ops

Total NFSv3 read operations

per sec

nfsv3_write_ops

Total NFSv3 write operations

per sec

nfsv3 object (7-Mode environments only)
Counter name

Description

Unit

nfsv3_avg_op_latency

Average latency of the NFSv3
operations

millisec

nfsv3_read_latency

Average latency, for NFSv3
read operations

millisec

nfsv3_read_size_histo

Histogram of NFSv3 read sizes

NA

nfsv3_write_latency

Average latency, for NFSv3
write operations

millisec

nfsv3_write_size_histo

Histogram of NFSv3 write
sizes

NA

nfsv4 object (7-Mode environments only)
Counter name

Description

Unit

nfsv4_ops

Number of total NFSv4
operations

per sec

nfsv4_read_ops

Number of NFSv4 read
operations

per sec

nfsv4_avg_latency

Average latency of an NFSv4
request

millisec

nfsv4_write_ops

Number of NFSv4 write
operations

per sec

nfsv4_read_size_histo

Histogram of NFS v4 read sizes NA

nfsv4_write_size_histo

Histogram of NFS v4 write
sizes

NA
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Perf object
Counter name

Description

Unit

data_disk_util_percnt_histo

Histogram of data disk
utilization

percent

ops_per_sec_histo

Histogram of operations
handled by the appliance

percent

parity_disk_util_percnt_histo

Histogram of parity disk
utilization

percent

Priority queue (7-Mode environments only)
Counter name

Description

Unit

max_user_reads

Maximum number of user reads NA
ever outstanding at one time for
this queue

nvlog_limit

Amount of nvlog this queue
might use during CP

NA

nvlog_limit_full

Number of times the nvlog
queue limit was hit during CP

NA

nvlog_used_max

Maximum amount of nvlog this NA
queue used during a CP

sys_read_limit

Limit on system reads
outstanding on this queue

NA

sys_sched_total

Number of scheduled system
requests

per sec

sys_weight

System request scheduling
weight within the priority
queue

NA

usr_read_limit

Limit on user reads outstanding NA
on this queue

usr_sched_total

Number of scheduling user
requests

usr_weight

User request scheduling weight NA
within a queue

per sec
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Prescheduled (7-Mode environments only)
Counter name

Description

Unit

bypass_rate

Rate at which guardrail
scheduler is bypassed

per sec

delayed_io_blocked

Number of times delayed
messages were found and all
queues were I/O blocked

NA

delayed_messages

Number of times a delayed
message was found and pushed

NA

preempt_rate

Scheduler preemption rate

per sec

queued

Current messages queued

NA

queued_max

Maximum scheduling queue
depth

NA

schedslow

Number of times scheduler was NA
found to be slow

wake_on_mesg_rate

Scheduler wake on message
received rate

per sec

wake_on_sig_rate

Scheduler wake on signal
received rate

per sec

Counter name

Description

Unit

domain_busy

Array of processor time spent
in various domains

percent

processor_busy

Percentage of elapsed time that
the processor is executing nonidle processes

percent

Processor object

qtree object (7-Mode environments only)
Note: To minimize negative performance impact on storage systems that Performance Advisor
monitors, the default performance views are not automatically generated for its qtree performance
objects. However, you can use the following counters to define performance views for individual
qtrees.
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Counter name

Description

Unit

nfs_ops

NFS operations per second

per sec

cifs_ops

CIFS operations per second

per sec

internal_ops

Number of internal operations
generated by activities such as
SnapMirror and backup to the
qtree

per sec

total_ops

Total operations on the qtree

per sec

System object
Counter name

Description

Unit

net_data_recv

Network KB received per second

per sec

net_data_sent

Network KB sent per second

per sec

disk_data_read

Disk KB read per second

per sec

disk_data_written

Disk KB written per second

per sec

cpu_busy

Percentage of time one or more
processors is busy in the system

percent

Note: For storage systems

running Data ONTAP 7.2 or
earlier, the cpu_busy counter is
the amount of time that any one
CPU is busy. This results in a
value for cpu_busy that is
inflated. For storage systems
running Data ONTAP 7.2.1 or
later, the cpu_busy counter is the
greater of either the average
CPU utilization or the busiest
domain.
avg_processor_busy Average processor utilization
across all processors in the system

percent

total_processor_bus
y

percent

Total processor utilization of all
processors in the system

disk_data_read_mbp MB read per second
s

mb per sec
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Counter name

Description

Unit

disk_data_written_
mbps

MB written per second

mb per sec

nas_throughput

Network throughput in a NAS
network

kb per sec

disk_throughput

Disk throughput in the storage
system or cluster

kb per sec

System object (7-Mode environments only)
Counter name

Description

Unit

cifs_ops

CIFS operations per second

per sec

dafs_ops

DAFS operations per second

NA

fcp_ops

FCP object operations per
second

per sec

http_ops

HTTP operations per second

per sec

iscsi_ops

iSCSI operations per second

per sec

nfs_ops

NFS operations per second

per sec

load_inbound_mbps

Total data received by the
system

mb per sec

load_outbound_mbps

Total data sent by the system

mb per sec

load_read_bytes_ratio

Ratio of the disk data read and
load outbound mbps

NA

load_total_mbps

Total data sent and received by
the system

mb per sec

load_write_bytes_ratio

Ratio of the disk data write and
load inbound mbps

NA

nc_urls

NetCache URLs served per
second

NA

pa_total_ops

Total operations on the system

per sec

pq_max_sys_reads

Maximum number of system
read requests ever outstanding
at one time for the default
queue

NA
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Counter name

Description

Unit

pq_max_user_reads

Maximum number of user reads NA
ever outstanding at one time for
the default queue

pq_nvlog_limit

Amount of nvlog default queue
might use during CP

NA

pq_nvlog_limit_full

Number of times the nvlog
queue limit was hit during CP
for the default queue

NA

pq_nvlog_used_max

Maximum amount of nvlog
queue used during a CP

NA

pq_sys_read_limit

Limit on system reads
outstanding on the default
queue

NA

pq_sys_sched_total

Number of scheduled system
requests for the default queue

per sec

pq_sys_weight

System request scheduling
NA
weight within the default queue

pq_usr_read_limit

Limit on user reads outstanding NA
on the default queue

pq_usr_sched_total

Number of scheduling user
requests for the default queue

pq_usr_weight

User request scheduling weight NA
within the default queue

san_throughput

Total SAN data sent and
received by the system

per sec

kb per sec

Target object (7-Mode environments only)
Counter name

Description

Unit

queue_full

iSCSI queue full responses per
second

per sec

read_ops

Read operations per second

per sec

write_ops

Write operations per second

per sec

other_ops

Other operations per second

per sec
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vFiler object (7-Mode environments only)
Counter name

Description

Unit

vfiler_cpu_busy

Percentage of CPU capacity
percentage
used per second by hosting
storage system that contains the
vFiler unit

vfiler_net_data_recv

Network data received in
kilobytes per second

kb per sec

vfiler_net_data_sent

Network data sent in kilobytes
per second

kb per sec

vfiler_read_ops

Read operations on the vFiler
unit

per sec

vfiler_write_ops

Write operations on the vFiler
unit

per sec

vfiler_misc_ops

Miscellaneous operations on
the vFiler unit

per sec

vfiler_read_bytes

Data read in kilobytes per
second on the vFiler unit

kb per sec

vfiler_write_bytes

Data written in kilobytes per
second on the vFiler unit

kb per sec

vfiler_data_transferred

Total data transferred by the
vFiler unit

kb per sec

vfiler_nw_throughput

Total network data received
and transmitted by the vFiler
unit

kb per sec

vfiler_total_ops

Total operations on the vFiler
unit

per sec

Volume object
Counter name

Description

Unit

total_ops

Number of operations performed by the
volume

per sec

avg_latency

Average latency for all the operations on
the volume

millisec

read_ops

Number of reads to the volume

per sec
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Counter name

Description

Unit

read_data

Bytes read from the volume

b per sec

read_latency

Average time for reads from the volume

microsec

write_data

Bytes written to the volume

b per sec

write_latency

Average time for writes to the volume

microsec

other_ops

Number of other operations to the
volume

per sec

other_latency

Average time for other operations to the
volume

microsec

write_ops

Number of writes to the volume

per sec

nfs_read_ops

Number of NFS reads to the volume

per sec

nfs_read_latency

Average time for NFS reads from the
volume

microsec

nfs_write_ops

Number of NFS writes to the volume

per sec

nfs_write_latency

Average time for NFS writes to the
volume

microsec

nfs_other_ops

Number of other NFS operations to the
volume

per sec

nfs_other_latency

Average time for other NFS operations to microsec
the volume

cifs_latency

Average time for CIFS operations to the
volume

millisec

cifs_ops

CIFS operations on the volume

per sec

cifs_read_ops

Number of CIFS reads to the volume

per sec

cifs_read_latency

Average time for CIFS reads to the
volume

microsec

cifs_write_ops

Number of CIFS writes to the volume

per sec

cifs_write_latency

Average time for CIFS writes to the
volume

microsec

cifs_other_ops

Number of other CIFS operations to the
volume

per sec
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Counter name

Description

Unit

cifs_other_latency

Average time for other CIFS operations
to the volume

microsec

san_read_ops

Number of block protocol reads to the
volume

per sec

san_read_latency

Average time for block protocol reads to
the volume

microsec

san_write_ops

Number of block protocol writes to the
volume

per sec

san_write_latency

Average time for block protocol writes to microsec
the volume

san_other_ops

Number of other block protocol
operations to the volume

per sec

san_other_latency

Average time for other block protocol
operations to the volume

microsec

flexcache_other_ops

Number of other FlexCache operations to per sec
the volume

flexcache_read_ops

Number of FlexCache read operations
from the volume

flexcache_write_ops

Number of FlexCache write operations to per sec
the volume

nfs_latency

Average time for NFS operations to the
volume

millisec

nfs_ops

user operations on the volume

per sec

sys_ops

sys operations on the volume

per sec

throughput

Total data sent and received by the
volume

b per sec

user_ops

user operations on the volume

per sec

per sec
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Volume object (7-Mode environments only)
Counter name

Description

Unit

pq_max_sys_reads

Maximum number of system
read requests ever outstanding
at one time for the default
queue for the volume

NA

pq_max_user_reads

Maximum number of user reads NA
ever outstanding at one time for
this queue in the volume

pq_nvlog_limit

Amount of nvlog this queue
might use during CP for the
volume

NA

pq_nvlog_limit_full

Number of times the nvlog
queue limit was hit during CP
for the volume

NA

pq_nvlog_used_max

Maximum amount of nvlog this NA
queue might use during CP for
the volume

pq_sys_read_limit

Limit on System reads
NA
outstanding on this queue in the
volume

pq_sys_sched_total

Number of scheduling system
requests with in the volume

per_sec

pq_sys_weight

System request scheduling
weight within the volume

NA

pq_usr_read_limit

Limit on user reads outstanding NA
on this queue in the volume

pq_usr_sched_total

Number of scheduling user
requests with in the volume

pq_usr_weight

User request scheduling weight NA
within the volume

per sec

Volume object (clustered environments only)
Counter name

Description

flexcache_other_ops

Number of other FlexCache operations to per sec
the volume

Unit
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Counter name

Description

Unit

flexcache_read_ops

Number of read FlexCache operations to
the volume

per sec

flexcache_write_ops

Number of write FlexCache operations to per sec
the volume

san_latency

Aggregated SAN latency at the volume
level

millisec

san_ops

SAN operations per second

per sec

volume:vserver object (clustered environments only)
Counter name

Description

Unit

other_ops

Aggregated number of other
operations to the volume at the
Vserver level

per sec

read_data

Aggregated bytes read from the b per sec
volume, at the Vserver level

read_ops

Aggregated number of reads to per sec
the volume, at the Vserver level

total_ops

Aggregated number of
operations performed by the
volume, at the Vserver level

write_data

Aggregated bytes written to the b per sec
volume, at the Vserver level

write_ops

Aggregated number of writes to per sec
the volume, at the Vserver level

per sec

volume:node object (clustered environments only)
Counter name

Description

Unit

other_ops

Aggregated number of other
operations to the volume at the
Vserver level

per sec

read_data

Aggregated bytes read from the b per sec
volume, at the Vserver level

read_ops

Aggregated number of reads to per sec
the volume, at the Vserver level
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Counter name

Description

Unit

total_ops

Aggregated number of
operations performed by the
volume, at the Vserver level

per sec

write_data

Aggregated bytes written to the b per sec
volume, at the Vserver level

write_ops

Aggregated number of writes to per sec
the volume, at the Vserver level

avg_latency

Average latency in
microseconds for the WAFL
file system to process all the
operations on the volume; not
including request processing or
network communication time

cifs_other_latency

Average time for the WAFL
microsec
file system to process other
CIFS operations to the volume;
not including CIFS protocol
request processing or network
communication time which will
also be included in client
observed CIFS request latency

cifs_other_ops

Number of other CIFS
operations to the volume

cifs_read_latency

Average time for the WAFL
microsec
file system to process CIFS
read requests to the volume; not
including CIFS protocol request
processing or network
communication time which will
also be included in client
observed CIFS request latency

cifs_read_ops

Number of CIFS reads to the
volume

microsec

per sec

per sec
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Counter name

Description

Unit

cifs_write_latency

Average time for the WAFL
microsec
file system to process CIFS
write requests to the volume;
not including CIFS protocol
request processing or network
communication time which will
also be included in client
observed CIFS request latency

cifs_write_ops

Number of CIFS writes to the
volume

per sec

flexcache_other_ops

Number of other FlexCache
operations to the volume

per sec

flexcache_read_ops

Number of FlexCache read
operations from the volume

per sec

flexcache_write_ops

Number of FlexCache write
operations to the volume

per sec

nfs_other_latency

Average time for the WAFL
microsec
file system to process other
NFS operations to the volume;
not including NFS protocol
request processing or network
communication time which will
also be included in client
observed NFS request latency

nfs_other_ops

Number of other NFS
operations to the volume

per sec

nfs_read_latency

Average time for the WAFL
file system to process NFS
protocol read requests to the
volume; not including NFS
protocol request processing or
network communication time
which will also be included in
client observed NFS request
latency

microsec

nfs_read_ops

Number of NFS reads to the
volume

per sec

48 | Performance Advisor Administration Guide
Counter name

Description

Unit

nfs_write_latency

Average time for the WAFL
file system to process NFS
protocol write requests to the
volume; not including NFS
protocol request processing or
network communication time
which will also be included in
client observed NFS request
latency

microsec

nfs_write_ops

Number of NFS writes to the
volume

per sec

other_latency

Average latency in
microseconds for the WAFL
file system to process other
operations to the volume; not
including request processing or
network communication time

microsec

read_latency

Average latency in
microseconds for the WAFL
file system to process read
request to the volume; not
including request processing or
network communication time

microsec

san_other_latency

Average time for the WAFL
file system to process other
block protocol requests to the
volume; not including block
protocol request processing or
network communication time
which will also be included in
client observed block protocol
request latency

microsec

san_other_ops

Number of other block protocol per sec
operations to the volume
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Counter name

Description

Unit

san_read_latency

Average time for the WAFL
file system to process block
protocol read requests to the
volume; not including block
protocol request processing or
network communication time
which will also be included in
client observed block protocol
request latency

microsec

san_read_ops

Number of block protocol reads per sec
to the volume

san_write_latency

Average time for the WAFL
file system to process block
protocol write requests to the
volume; including block
protocol request processing or
network communication time
which will also be included in
client observed block protocol
request latency

microsec

san_write_ops

Number of block protocol
writes to the volume

per sec

write_latency

Average latency in
microseconds for the WAFL
file system to process write
request to the volume; not
including request processing or
network communication time

microsec

List of CLI commands
You must be aware of some CLI commands in order to perform certain operations such as creating a
view, modifying thresholds, listing counters, and managing performance diagnostics, in Performance
Advisor.
The CLI commands in the following table are applicable to both 7-Mode and clustered environments:
CLI command

Description

dfm perf counter list

Lists the performance counters for the storage
object
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CLI command

Description

dfm perf threshold list

Lists the performance thresholds

dfm perf threshold create

Creates the performance thresholds

dfm perf threshold delete

Deletes the performance thresholds

dfm perf threshold refresh

Refreshes the performance thresholds

dfm perf threshold modify

Modifies the performance thresholds

dfm perf threshold filter list

Lists the performance thresholds based on filter

dfm perf data list

Lists information about all the counter groups

dfm perf data describe

Describes the counter group

dfm perf data retrieve

Retrieves the performance data of the storage
object

dfm perf view describe

Describes the performance views

dfm perf view list

Lists the performance views

CLI command (7-Mode environments only)

Description

dfm perf view create

Creates a view

dfm perf view counter add

Adds a performance counter

dfm perf view counter delete

Deletes a performance counter

dfm perf view chart add

Adds a performance chart

dfm perf view chart delete

Deletes a performance chart

dfm perf view destroy

Destroys the performance view

dfm perf template create

Creates the threshold templates

dfm perf template detach

Removes the threshold templates

dfm perf template attach

Attaches the threshold templates

dfm perf template list

Lists the threshold templates

dfm perf template delete

Deletes the threshold templates

dfm perf template modify

Modifies the threshold templates

dfm perf template threshold add|
modify

Modifies the threshold template
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CLI command (7-Mode environments only)

Description

dfm perf export counter list|add|
delete

Manages data export for counter groups

dfm perf data modify

Modifies the data collection configuration

dfm perf data export

Manages data export

dfm perf data enable|disable

Enables or disables the counter group

dfm perf diag

Manages performance diagnostics

dfm perf clientstats

Manages client statistics

dfm perf clientstat collect

Collects the client statistics

dfm perf clientstat list

Lists the client statistics

dfm perf clientstat purge

Removed the client statistics that was collected

dfm perf data copy

Copies the data collection configuration
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What access permission is
Access permissions allow you to customize views, change storage system settings, set event
thresholds, and configure events and alarms.
You can use role-based access control (RBAC) to grant access to the user. The access to resources is
defined and controlled based on the role or job function of a user.

RBAC for configuring views (7-Mode environments only)
You must be aware of the capabilities you require to configure custom views for the objects you are
monitoring.
The following table lists the tasks you can perform to configure views and the required capabilities:
Task

Capability

Object

View the performance data of a Database Read
counter in a view

Managed object associated with
the counter instance in the view

Create a custom view

PerfView Write

Global

Modify a custom view: Add a
counter

PerfView Write

Global

Modify a custom view:
Remove a counter

Database Read

Managed object associated with
the counter instance in the view

Modify a custom view: Rename PerfView Write
a view

Global

Delete a custom view

PerfView Delete

Global

View real-time performance
data

PerfView RealTimeRead

Global

Note: Requires the Database
Read Capability

RBAC for modifying storage system settings (7-Mode
environments only)
You must be aware of the capabilities you require to configure the storage system settings.
The following table lists the tasks and the required capabilities for modifying the storage system
settings:
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Task

Capability

Object

Modify a custom view:

Database Write

Storage system

•
•

Change credentials
Change the transport
protocol

RBAC for setting thresholds
The tasks and capabilities available for storage objects are based on the RBAC settings. You can
create, view, or edit thresholds based on the RBAC.
The following table lists the tasks and the capabilities related to the threshold operations, and the
objects for which you can perform these operations:
Task

Capability

Object

You can create or edit
thresholds on the counters of
the following objects:

Database Write

On each instance of the object

•
•
•
•
•
•
•
•
•
•

(clustered environments
only) Vservers
(clustered environments
only) Nodes
(7-Mode environments
only) vFiler units
(7-Mode environments
only) Qtrees
(7-Mode environments
only) Targets
Aggregates
Volumes
LUNs
Disks
Network interfaces
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Task

Capability

You can view thresholds on the Database Read
counters of the following
objects:
•
•
•
•
•
•
•
•
•
•

•
•
•
•
•
•
•
•
•

On each instance of the object

(clustered environments
only) Vservers
(clustered environments
only) Nodes
(7-Mode environments
only) vFiler units
(7-Mode environments
only) Qtrees
(7-Mode environments
only) Targets
Aggregates
Volumes
LUNs
Disks
Network interfaces

Database Write
You can create or edit
thresholds on the counters of all
the storage objects, such as the
following:
•

Object

(clustered environments
only) Vservers
(clustered environments
only) Nodes
(7-Mode environments
only) vFiler units
(7-Mode environments
only) Qtrees
(7-Mode environments
only) Targets
Systems
NFSv3
CIFS
FCP
iSCSI

Storage systems
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Task

Capability

You can view thresholds on the Database Read
counters of all the storage
objects, such as the following:
•
•
•
•
•
•
•
•
•
•

Object
Storage systems

(clustered environments
only) Vservers
(clustered environments
only) Nodes
(7-Mode environments
only) vFiler units
(7-Mode environments
only) Qtrees
(7-Mode environments
only) Targets
Systems
NFSv3
CIFS
FCP
iSCSI

RBAC for threshold templates (7-Mode environments only)
You must be aware of the capabilities required to configure threshold templates by using role-based
access control (RBAC).
The following table lists the threshold template operations that you can perform on objects, the
capabilities you require, and the objects on which you can perform the operation:
Task

Capability

Create or edit threshold
templates

PerfThreshTemplate Write

View threshold templates

PerfThreshTemplate Read

Object
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Task

Capability

Object

Apply or remove a threshold
template on the following
objects:

Database Write

On each instance of the object

•
•
•
•
•
•
•
•
•

Storage system or a group
of storage systems
Aggregate
Volume
Qtree
LUN
Disk
Network interface
vFiler units
Targets

RBAC for configuring events (7-Mode environments only)
You must be aware of the capabilities you require to configure events for the objects you are
monitoring. You can configure events by using role-based access control (RBAC).
The following table lists the capabilities required to configure threshold templates:
Task

Capability

Object

View an event

Event Read

Source of the event

Delete an event

Database Write

Source of the event

Acknowledge an event

Event Write

Source of the event

RBAC for configuring alarms (7-Mode environments only)
You must be aware of the capabilities you require to configure alarms for the objects you are
monitoring.
The following table lists the tasks you can perform to configure alarms and the required capabilities:
Task

Capability

Object

Creating an alarm

Alarm Write

Group associated with the
alarm

Modifying an alarm

Alarm Write

Group associated with the
alarm
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Task

Capability

Object

Deleting an alarm

Alarm Delete

Group associated with the
alarm

Listing all alarms

Alarm Read

Group associated with the
alarm
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Requirements to install Performance Advisor
Before you use Performance Advisor, you must install NetApp Management Console and ensure that
the prerequisites are met.
The prerequisites to access Performance Advisor are as follows:
•
•
•
•
•

The NetApp Management Console must be installed.
The performance-monitoring server must be enabled.
The DataFabric Manager server must be installed.
You must install Data ONTAP 6.5 or later on all storage objects and the hosts of all the vFiler
units for which you want to monitor performance data.
You must display the storage objects and vFiler units for which you want to monitor performance
data to the DataFabric Manager server.
Note: For details about downloading and installing the NetApp Management Console, see the
OnCommand Unified Manager Installation and Setup Guide. When upgrading to DataFabric
Manager server 3.6 or later, the application graphs that show the calculated statistics display data
for the period after the upgrade.

Enabling the performance-monitoring server
Before you start NetApp Management Console and log in to Performance Advisor, you must enable
the performance-monitoring server.
Steps

1. In the Operations Manager console, select Control Center > Setup > Options > Performance
Advisor.
The Performance Advisor options are displayed.
2. If NetApp Management Console is disabled, from Performance Advisor Options, select
Performance Advisor Enabled > Enabled.
You can perform this task if the performance-monitoring server is disabled.
3. Click Update.

Setting up transport protocols between the performancemonitoring server and Performance Advisor
By default, both HTTP and HTTPS are enabled as transport protocols between the performancemonitoring server and Performance Advisor. You can change the transport protocol and
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performance-monitoring server ports by using the Performance Advisor options in the Operations
Manager console.
Steps

1. In the Operations Manager console, select Control Center > Setup > Options > Performance
Advisor to display the Performance Advisor options.
2. Select one or more of the following options to accept or modify the settings as appropriate to your
environment:
•

•

•

•

Server HTTP Port
This option sets the port used by the performance-monitoring server to receive HTTP
connections from the application. The default value is 8088.
Server HTTP Enabled
This option enables or disables HTTP as a transport protocol used by the application. The
default value is Yes.
Server HTTPS Port
This option sets the port used by the performance-monitoring server to receive HTTPS
connections from the application. The default value is 8488.
Server HTTPS Enabled
This option enables or disables HTTP as a transport protocol used by the application. The
default value is Yes.

3. Click Update.

Setting up appliance-level transport between Performance
Advisor and monitored devices
You can edit the Performance Advisor Transport setting for an individual storage system or a
vFiler host by using the Operations Manager console. You can specify whether the individual device
can use HTTP only or use both HTTP and HTTPS as the transport protocols between Performance
Advisor and the performance-monitoring server.
Steps

1. Click the name of the device in the Operations Manager console.
2. Click Edit Settings.
3. Select the options you want from the Performance Advisor Transport list.
4. Click Update.
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Setting up transport protocols between Performance
Advisor and monitored devices
You can set up transport protocols between Performance Advisor and monitored devices by enabling
both HTTP and HTTPS or enabling HTTPS only as transport protocols in Operations Manager
console.
Before you begin

There must be no conflicting transport setting between Performance Advisor and the individual
storage systems.
Steps

1. In the Operations Manager console, select Control Center > Setup > Options > Performance
Advisor to display the Performance Advisor options.
2. Select one of the following Performance Advisor Transport options to accept or modify the
settings as appropriate to your environment:
•

•

httpOnly
Specifies HTTP only as the global transport protocol between the performance-monitoring
server and all the monitored devices. This is the default setting.
httpsOk
Enables both HTTP and HTTPS as global transport protocols between the performancemonitoring server and all the monitored devices.
Note: When the transport protocol for the host is HTTPS, you must not set the Performance
Advisor Transport option to HTTP.

3. Click Update.
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Getting started with the Performance Advisor user
interface
By using the NetApp Management Console, you can login to the DataFabric Manager server to
access and start or stop the Performance Advisor application.

Starting Performance Advisor
You can start monitoring the performance of storage objects and systems by starting Performance
Advisor from the NetApp Management Console.
Steps

1. Click Start > All Programs > NetApp > Management Console.
2. Enter the fully qualified domain name, user name, and the password for the DataFabric Manager
server you want to log in to.
The user name, domain name, transport, and port number from your previous login session are
saved. Therefore, if you are logging in as the same user as before, you have to enter only your
password.
3. Select HTTP or HTTPS transport.
The default port is selected automatically. If you log in using any other port, you must set the
serverHTTPSPort option to the matching port.
4. Click Connect.
5. Click Manage Performance to display the top-level groups configured for the DataFabric
Manager server that you have logged in to.

Disconnecting from Performance Advisor
You can stop Performance Advisor when you have completed the performance analysis of the
storage objects in your environment by closing NetApp Management Console.
Step

1. From the menu, Select File > Exit.

Storage objects unavailable in Performance Advisor
Some storage objects might be unavailable in Performance Advisor under certain circumstances.
Storage objects that are not available are displayed in the Set Up Storage Systems window in 7-Mode
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environments, and the Set Up Cluster window in clustered environments, and not in the View
navigation pane.
Storage objects might be unavailable under the following conditions:
•
•
•
•
•
•

Storage objects are running Data ONTAP versions earlier than 6.5.
The DataFabric Manager server is not managing storage objects.
Data collection from the DataFabric Manager server by the application is not enabled.
You do not have sufficient access privileges to these storage objects.
If the login credentials used to access the storage system are incorrect, Performance Advisor will
not continue data collection.
If there is a mismatch in the protocols (perfadvisortransport) used by the performance monitoring
server and the storage system.

Unavailable menu options in the Performance Advisor
interface
The availability of menu options in the Performance Advisor interface is determined by your
DataFabric Manager server administrator roles. Options that are dimmed are not available to you for
the storage system or vFiler unit you have currently selected.

Zero-value data in a Performance Advisor chart
When the performance-monitoring server sends nothing but zeros to Performance Advisor for the
counter or counters in a chart, this is called zero-value data.
Zero-value data is displayed for any counters monitoring protocols that are not enabled on the storage
system or vFiler unit. A chart displaying only zero-value data shows a vertical axis numbered from 0
to 1, and vertical lines, but no graph.

Lack of data in a Performance Advisor chart
If a chart does not contain any data, it indicates that the performance-monitoring server has not sent
any data to Performance Advisor for the counters in the chart for the period displayed.
An empty chart indicates that you cannot access the data. This situation is unlikely, unless one of the
following conditions is true:
•

You are viewing SnapMirror counters for a storage system that does not have a SnapMirror
license.

•

If LUNs are not available, then the "Top N luns" chart does not display any data.

•

If qtrees are not available, then the "Top qtrees in a dataset" chart does not display any data.
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•
•

If the FlexShare option is turned off, then the "Priority queue" chart does not display any data.
Performance Advisor has not collected any performance data.
You can verify this by using the dfm perf data retrieve command.

Display of new storage objects in Performance Advisor
When the DataFabric Manager server discovers new storage systems or clusters, or when you
manually add storage systems or clusters, you must refresh the display for the application to list the
new devices.
You must press F5 to refresh the display.
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Overview of the NetApp Management Console
dashboard
The NetApp Management Console provides an overview of various aspects of your data management
environment, including monitoring information.
Monitor
dashboard

The Monitor dashboard in Performance Advisor displays information about the
current overall performance status of your systems, such as performance events, top
storage systems by the total number of operations, top storage systems by network
throughput, top storage systems by CPU utilization, Top Nodes by CPU Utilization
and Top Vservers by Total Ops. You can modify the default settings to configure
any view on the global group as a dashboard.

Dashboard panel descriptions
The dashboard panels provide a cumulative at-a-glance status information about your system.
Performance Advisor dashboard
You can view more details about the Performance Advisor dashboard by clicking
dashboard panel title bar.

in the

Dashboard panels (clustered environments only)
Top Performance
Events

Displays the five events with the highest severity levels. Items are ordered
first by severity, then by time that they occurred. More detail about each
event is provided in Monitor > Events.

Top Nodes by CPU
Utilization

Displays a bar chart of the top five nodes that are discovered and monitored
by the DataFabric Manager server, and sorted by the highest CPU
utilization. The vertical axis displays the percentage of CPU utilization for
that node. The horizontal axis displays the node name.

Top Vservers by
Total Ops

Displays a bar chart of the top five Vservers that are discovered and
monitored by the DataFabric Manager server, and sorted by the highest total
operations. The vertical axis displays the total operations per second for that
Vserver. The horizontal axis displays the Vserver name.
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Dashboard panels (7-Mode environments only)
Top Performance
Events

Displays the five events with the highest severity levels. Items are ordered
first by severity, then by time that they occurred. More detail about each
event is provided in Monitor > Events.

Displays a bar chart of the top five storage systems, sorted by the highest
Top Storage
Systems by Network network throughput. The number above each bar chart displays the exact
value of the throughput per second from that system. The vertical axis
Throughput
displays the megabytes of throughput per second. The horizontal axis
displays the name of the storage system.
Top Storage
Systems by Total
Ops

Displays a bar chart of the top five storage systems, sorted by the highest
total operations. The vertical axis displays the total operations per second
for that storage system. The horizontal axis displays the storage system
name.

Top Storage
Systems by CPU
Utilization

Displays a bar chart of the top five storage systems, sorted by the highest
average CPU utilization. The number above each bar chart displays the
exact value of the throughput per second from that system. The vertical axis
displays the percentage CPU usage of the storage system. The horizontal
axis displays the name of the storage system.

What events are
Events are generated automatically when a predefined condition occurs or when an object crosses a
threshold. These events enable you to take action to prevent issues that can lead to poor performance
and system unavailability. Events include an impact area, severity, and impact level.
Events are categorized by the type of impact area they encompass. Impact areas include availability,
capacity, configuration, or protection. Events are also assigned a severity type and impact level that
assist you in determining if immediate action is required.
You can configure alarms to send notification automatically when specific events or events of a
specific severity occur.
Events are automatically logged and retained for a default of 180 days.
Event types are predetermined. You can manage event notification, but you cannot add or delete
event types. However, you can modify the event severity by using the command-line interface.

Configuring events
You can learn about event occurrences by viewing the event log or by configuring alarms to
automatically notify you when events occur.
•

Viewing the event log
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•

You can use the Events window to view a list of all the events that occurred and to view detailed
information about any selected event.
Configuring alarms
You can use the Alarms window to add an alarm that sends notifications automatically when an
event occurs.

Monitoring events
You can view a list of all the events that occurred and view detailed information about any event.
You can also view events that are marked for deletion.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. You can monitor events from the NetApp Management Console or Performance Advisor.
To monitor events from...

Do this...

The NetApp Management Console

From the menu bar, click Notifications > Events.

Performance Advisor

From the menu bar, click Monitor > Events.

2. Optional: Customize the Events window in one of the following ways:
•
•
•

Select an event to view details about that event.
in the column header to control the event entries that you want displayed.
Click
Click the sort arrows in the column header to change the sort order of the entries in that
column.

•
•

in the upper-right corner of the list to select which columns are displayed.
Click
Drag the bottom of the events list area up or down to resize that area.

3. Optional: View the events that are marked for deletion by displaying hidden columns and
removing a text filter, as follows:
in the upper-right corner of the list and select the Deleted By and Deleted Time
a) Click
columns.
b) Click
in the Deleted By column header and delete the default search string.
The default filtering of deleted events is stopped and the deleted event entries are displayed in
the list.
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Responding to and acknowledging events
When an event occurs, you must take appropriate action to acknowledge and manage it and correct
the problem. Responding to an event includes viewing it, acknowledging it, and correcting the
problem.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. From the menu bar, click Notifications > Events. For Performance Advisor, from the menu bar,
click Monitor > Events.
2. In the Events window, select an event to view the details about it.
3. Select an event and click Acknowledge to indicate that you are taking responsibility for
managing that event.
4. In the Acknowledge Events dialog box, click Yes to acknowledge the selected event.
Your user name and the time are entered in the Events list for the selected event.
5. Find the cause of the event and take corrective action.

Deleting events
You can delete an event from the event list. Typically, you delete an event only after you
acknowledge it and resolve the problem. However, you can also delete unacknowledged events if
they are not important.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. For protection, provisioning, or disaster recovery events, from the menu bar, click Notifications
> Events. For Performance Advisor events, from the menu bar, click Monitor > Events.
2. In the Events window, select an event and click Delete.
3. In the Delete Events dialog box, click Yes to delete the selected event.
4. Verify that the event is deleted by viewing the Events window.
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After you finish

You can view events that are marked for deletion by clicking

in the corner of the list.
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Views in Performance Advisor
You can use views in Performance Advisor to analyze and interpret performance data.

What the performance view window is
The performance view window enables you to view the performance data of the selected group or the
object in the hierarchy.

What predefined views are
Predefined views are default and system-generated views that are available in Performance Advisor.
You can use predefined views to view performance data, which is collected by the performancemonitoring server and displayed in Performance Advisor.
You cannot edit or delete predefined views. However, in 7-Mode systems, you can save a copy of the
predefined view and create a custom view.
For example, you might want to monitor the physical objects with the most performance. The default
view is Storage System Summary View. Using the Views list, you can set the Storage System - Top
Physical Objects view for the storage systems to be displayed as the default view. The Storage
System Summary View is no longer the default view that appears when you click the storage
systems.
Note: If you change the default view of the global group, then the Dashboards window uses the
new view to display the panels.

What custom views are (7-Mode environments only)
You can create custom views through the Performance Advisor interface so that you can monitor one
or more specific storage objects. In a single custom view, you can add multiple counters from a
single chart or multiple charts. By default, custom views are associated with the Global group.
You can combine any counters you want for display in a single view. Additionally, you can include
multiple counters in a single chart, and multiple charts in a single view. By default, custom views are
associated with the Global group.
Note: Although you can combine any counters in a single chart, if you combine counters with
different units, the chart displays multiple vertical (“y”) axes with the respective unit labels of the
counters. For example, combining the disk_data_read counter (KB per second) with the
processor_busy counter (percentage) results in a chart with multiple vertical (“y”) axes, where
each axis displays the respective unit label of the counter.
Note: On upgrading to the DataFabric Manager server 3.6 or later, multiple custom views with the
same name in the earlier versions of Performance Advisor are displayed in the view name>_view
Id format. For example, if there are multiple custom views with the same name cv1, then after the
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upgrade, these custom views are shown in the cv1_view Id format. Because the view Id is unique,
the custom view name is unique after the upgrade.
You can create custom views to perform the following actions:
•
•
•

Access real-time data, other than what appears in the default view
Group counters into combinations that are not offered by default views
Use a chart type different from the charts in the default view
You can temporarily select a different chart type in a default view through the right-click menu.
However, the view returns to the default chart type each time you invoke it from the navigation
pane.

What advanced views are
Advanced views enable you to view the performance data based on statistical parameters for a period
of time. You can set parameters such as minimum, maximum, mean, and percentile on the collected
data for further consolidation.
These views enable you to set the baseline for data collection and thus help you to set appropriate
thresholds. The following are the three types of computations that are applicable to the statistical
parameters:
•

•

•

Simple
This is a single value of the statistical parameter for the whole period of time. A horizontal line is
displayed in the view.
Step
The values are accumulated for a specified period. This calculation yields multiple values and
displays a series of horizontal lines in steps.
Rolling
The values are accumulated for a specified period in regular intervals. This calculation yields
multiple values and displays smoothened lines.

The statistical computations are based on the Boost.Accumulators library.
Note: Computation types in advanced views are calculated based on the unconsolidated
performance data. In the other views, data is graphically represented based on the consolidated
performance data (using the performance settings.) Therefore, the baseline might not meet the
graph in the advanced views. This might result in inconsistencies in the advanced views.
Related information

Accumulators: www.boost.org/doc/libs/1_38_0/doc/html/accumulators.html
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Types of data in Performance Advisor
You can use historical data for diagnosing past performance problems or for short-term trend
analysis, and you can use real-time data (7-Mode environments only) for diagnosing immediate
performance issues by either saving or exporting the data for analysis.
The following types of data are available in Performance Advisor:
•

•

Historical data
Historical data is data that is archived on the DataFabric Manager server. The data is collected on
an ongoing basis, irrespective of whether the performance view is open.
Real-time data (7-Mode environments only)
Real-time data is data that is sent through the performance-monitoring server and displayed in
Performance Advisor. The data is collected only as long as a performance view displaying it is
open in the Performance Advisor interface. Unlike historical data, real-time data is not stored.
Note: In clustered environments, when you move a volume from one aggregate to another
aggregate within the same node, or between aggregates of different nodes, Performance Advisor
does not retain the historical data.

Logical and physical objects hierarchy
You can view the hierarchy of logical and physical objects in the navigation tree from the navigation
pane. By default, the hierarchy of logical objects hierarchy is displayed in the navigation pane.
For clustered environments, the logical hierarchy displays clusters at the top level, which in turn
displays Vservers, LUNs, and volumes.
The physical hierarchy includes the cluster, nodes, disks, LUNs, processors, and aggregates.

Viewing historical data
You can view and analyze the historical data by selecting the time range on a chart. You can update
the time range on all charts by synchronizing the time axes.
Steps

1. From the View tab, select a view from the Available Views list.
2. Select the chart in a view.
3. Click Range > Custom.
4. Edit Start Date and End Date.
5. Click Ok.
Result

The chart is refreshed to display the historical data for the time range specified.
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What synchronizing time axes is
You can synchronize the axes when you want the time axes of all line charts in a view to be in sync.
It helps in detecting performance blockage by interpreting data through views.
For example, if you observe a spike in one of the charts in the Summary View window, you can
probe further by interpreting data in the related charts of the window. You must synchronize the time
axes on all charts to investigate the data for a particular time period.

Viewing historical data
You can view the historical data of an object by selecting the object in the navigation tree.
About this task

You can also view the performance data of an object by using the Open View wizard.
Steps

1. From the menu bar, click View.
2. Expand the storage objects in the navigation tree to view the storage objects (child objects) within
them.
The parent object displays a tree of objects.
3. Click the object for which you want to view the data.
The default view of the selected object is displayed.
Note: You can change the default view by using the Set Default button.

Displaying tabbed views
You can view the performance data of multiple groups or objects at the same time using tabbed
views.
Steps

1. From the menu bar, click View.
2. Right-click an object in the navigation pane.
3. Click Open in New Tab.
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Selecting a performance view
You can select a performance view from a list to view the performance view of your choice. The
Available views list in performance view window displays a list of various types of performance
views.
Step

1. In the Summary View window, select the view from the Available Views list.

Closing a performance view
You can close any current view by using the x icon.
Step

1. Click the x icon.

Actions you can perform in the performance views
You can view and analyze data in performance views by using charts. You can perform many actions
in performance views such as list storage objects, manage the performance charts, add a counter and
threshold.
You can view and analyze either 7-Mode or cluster data by performing the following actions on
performance charts:
•

List all related objects using the arrow icon in the upper-right corner of the title bar in the chart.
Clicking the arrow displays a tree view of objects related to the content of the chart.
Note: In clustered environments, LUNs are not displayed as related objects for nodes.

•
•
•
•
•
•
•

Select the range of data to be displayed, such as performance details collected for the past one
hour.
Zoom in to the chart by 10%.
Zoom out of the chart by 10%.
Reset the axes.
Add one or more thresholds.
Save as an image file.
Print the chart.

In addition, you can perform the following actions in 7-Mode environments only:
•

•

Plot the Performance Advisor events on the chart and identify the cause of the increased rates or
decreased throughput.
You can identify the nature of the event by moving the pointer over the plotted event.
Add one or more counters.
In a custom view, when you stop the data collection, the historical view chart displays a blank
space from the point of time the data collection was stopped. When the data collection is
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restarted, the polyline graph connects the point at which the data collection was stopped to the
point where the data collection is restarted. To identify the break in the data collection, you
should go to the respective scatter graph to know whether there is any disconnection.
If a chart contains managed objects and unmanaged objects, the tree view of the object that is
displayed in that particular chart displays only the managed objects. The tree view is blank if any
chart contains unmanaged objects.
You can maximize or minimize the chart by double-clicking its title. Any view that contains only one
chart is always maximized.

Viewing the time period in a chart
You can view the performance details for the selected portion of time by moving the time period
axis.
About this task

The screen resolution determines the amount of data that is displayed (as opposed to the entire range
of data you can scroll to). Therefore, resizing a chart does not increase or decrease the amount of data
you can view; it only increases or decreases the number of pixels per data point. The zoom buttons
help you compress or lengthen the time scale and modify the time period that is displayed in the
chart.
Step

1. View the performance data by clicking the appropriate button near the Show Threshold check
box.

Resetting both axes
You can reset the axes in any chart of a view. The “x” or horizontal axis represents time in line charts
and objects in bar charts. The units on the “y” or vertical axis vary, depending on the counters
included in the chart.
Step

1. Click Action > Reset Both Axes.
Alternatively, right-click anywhere in the chart and click Reset Both Axes.

Synchronizing time axes
You can synchronize the time axis in charts by using Performance Settings and activating
Synchronize in a view.
Steps

1. Click the Performance Settings icon in the menu bar.
2. Select one of the following options to accept or modify the settings:
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•
•

Synchronize all charts in a view
Synchronize all charts across all views

3. Click View and select a view from Available views.
4. Click View Actions > Synchronize.

Undoing synchronization of time axes
You can undo the synchronization of the time axis in charts by using Undo synchronize in a view.
Steps

1. Click View and select a view from Available views.
2. Click View Actions > Undo synchronize.

How to use the legend for predefined views and custom views
You can use the legend in predefined views to interpret the performance data that is displayed. Each
performance view includes a legend.
The legend for a predefined view contains the following information:
•
•
•
•

A sample of the graph color
The name of the counter
Unit of x-axis
Unit of y-axis

In addition to the above, the legend for a custom view includes the name of the storage object,
subsystem, or group of storage object units from which the data is collected
Using the legend, you can select the counters that you want to view in the performance chart.

How to view thresholds
You can view thresholds along with the performance data for a counter using views.
You can select the Show thresholds check box located next to the Show legends check box to view
thresholds. The dotted lines that appear in the chart indicate the threshold values.

Creating advanced views
You can create advanced views for any storage system by using the View window, to gather
additional information about the storage system performance.
Steps

1. From the NetApp Management Console navigation pane, click View.
2. Select the storage system for which you want to create the advanced view.
3. Click View Actions > Metrics.
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4. Click Metric Settings.
5. Select metric and computation types with period settings.
6. Click Add metric and then click Ok.
7. Click Filter Settings.
8. Specify the time and day of the week and click Ok.

Adding thresholds using a view
You can use a view to add thresholds for the counters displayed on the chart.
Steps

1. Click View and select a view from Available views.
2. Right-click the chart.
3. Move the pointer over Add Threshold and click a counter.

Changing the chart type
You can identify the breaks in data collection by changing the type of chart.
Steps

1. Display the performance view.
2. Right-click the chart.
3. Move the pointer over Chart Type and click Scatter Chart.

Pausing data collection
You can play or pause the data collection if you want to examine a graph in detail. This is useful if
the graph is updated frequently.
Steps

1. Select a view from View > Available views.
2. Click View Actions.
3. Click Pause once to pause data collection.
However, the DataFabric Manager server does not stop collecting data.
4. Click Play to restart the data collection.
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Printing a chart from a view
You can print a chart by clicking in the view.
Steps

1. Identify the performance view that you want to print and right-click in the chart.
2. Click Print.
3. Specify the name of the printer and click Ok.

Enabling charts to scale the y axis
You can enable charts to scale the vertical axis automatically for best view during various periods of
data collection.
Steps

1. Display the performance view.
2. Right-click in the chart.
3. Click Auto Scale Y-Axis.

Diagnosing a performance issue (7-Mode environments only)
If the storage system is facing a performance bottleneck, you can diagnose the performance issue by
checking the health of Data ONTAP, network, NAS, and SAN.
About this task

During the diagnosis of a storage system, Performance Advisor investigates the following: Data
ONTAP, Network, NAS, and SAN.
Steps

1. From the menu bar, click View.
2. Open a performance view of a storage system.
3. Click View Actions.
4. Click Diagnose.
5. Select the time for which you want to collect data.
6. Click Diagnose.
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After you finish

After Performance Advisor diagnosis the performance issue, it provides observations and
recommendations for each category. You must check the details of each category and act on the
recommendations, if necessary.

Performance monitoring with custom views (7-Mode
environments only)
Custom views enable you to display data in combinations or styles, depending on your requirements.
For example, you might want to monitor a single counter across several storage systems or vFiler
units. You might want to use predefined views to view counter combinations, but in a different type
of chart.

When must you create a custom view (7-Mode environments only)
You must create a custom view if you want to access real-time data, display counters in combinations
that are not offered by predefined views, use chart types different from that of predefined views, and
use different views to compare the performance of the same counter on different objects.
You can temporarily select a different chart type in a predefined view through the right-click menu.
However, the view returns to the default chart type each time you open it from the Performance
Views panel.

How data from counters is displayed (7-Mode environments only)
Counter data is shared across different views. Any data collected for a counter in other performance
views is displayed in a new view. When you add a counter to a performance view, if data collection
is enabled for this counter in another view, then the new view displays the data collected in the other
view.

Viewing real time data (7-Mode environments only)
You can access and view real-time data from Performance Advisor. By default, all the performance
views display historical data in Performance Advisor.
About this task
Note: Real-time data collection can increase storage system CPU utilization, which might
negatively impact the performance of the storage system.
Steps

1. From the View tab, select a view from the Available Views list.
2. Click View Actions > Real Time.
3. Select Real Time.
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4. Select Sample Rate and Retention Period.
5. Click Ok.
6. Click Yes to the Performance Warning message.

Creating a custom view (7-Mode environments only)
You can create a custom view with selected counters in bar and line charts, to analyze specific
parameters in Performance Advisor.
Before you begin

You must be assigned the DataFabric Manager GlobalWrite and GlobalDelete roles.
About this task

Although you can combine any counters in a single chart, combining counters with different units
results in a chart with multiple vertical (“y”) axes. For example, combining the disk_data_read
counter (KB per second) with the processor_busy counter (percentage) results in a chart with
multiple vertical (“y”) axes, where each y axis represents the respective unit labels of the counters.
Steps

1. Click Set Up > Custom Views.
2. Click Add.
3. In the View name field, type the name of the custom view that you want to create.
The custom view names should be unique.
4. Select the storage object for which you want the view to be created.
5. Click Add Chart so that you can display the data in graphs.
You can add more than one chart to the view.
6. Select Show events to display the top five events for each object that is associated with the view.
7. Click Add.

Opening a custom view (7-Mode environments only)
You can open a custom view in the performance view window to see information about the selected
storage object counters. You can open a custom view only for the associated storage object.
Steps

1. Click Set Up > Custom Views.
2. Select or right-click the custom view and click Open.
If you create a custom view for a particular storage object, then Open is enabled.
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Editing custom views (7-Mode environments only)
You can edit the view name, the chart name, and the counter details in a custom view.
Before you begin

You must be assigned the GlobalWrite and GlobalDelete roles.
About this task

You cannot edit predefined views.
Steps

1. Click Set Up > Custom Views.
2. Edit the custom view in one of the following ways:
•
•

Select the custom view and click Edit.
Right-click the selected custom view and click Edit.

3. In the properties sheet for the selected custom view, click the fields you want to modify, and enter
the new values.
4. Click Apply.

Deleting a custom view (7-Mode environments only)
You can delete a custom view from the Custom Views window if it is no longer required.
Before you begin

You must be assigned the GlobalWrite and GlobalDelete roles.
About this task

You can delete only custom views, not predefined views.
Steps

1. Click Set Up > Custom Views.
2. Select one or more custom views in the Custom Views window and click Delete.
3. Click Ok.
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CPU utilization limitations on storage systems or vFiler hosts
The performance-monitoring settings might increase the storage system CPU utilization beyond
expected levels.
You must check the current CPU utilization level on the storage system or vFiler host before you
perform the following operations:
•
•

Enable SecureAdmin on a storage system, which requires the DataFabric Manager server to use
HTTPS to monitor performance data
Switch the data source in views to real time (7-Mode environments only)

Analysis of real-time data (7-Mode environments only)
You must either save or export the real-time data to analyze it. The real-time data is not archived and
exists only when the performance view is displayed.

Methods for saving performance data
You can save the performance data of a storage object for analysis in Performance Advisor by using
the Save as option or the Export option.

Saving a chart
You can save the chart of the performance view with details in your directory.
About this task
Note: To get a good result for a .png file with proper details, you should maximize the chart view
by double-clicking the title bar of the chart and then save the chart.
Steps

1. Display the performance view.
2. Right-click the chart.
3. Click Save as.
4. Select the directory in which you want to save the chart.
5. Specify the name of the file.
6. Click Save.
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Exporting a view to a .csv file
You can export the data from a view to a .csv (comma-separated value) file for analysis.
About this task

You can export performance data; however, you should be aware of the following limitations:
•
•

Exporting data is disabled for top performance charts.
If a view has top performance charts and detailed charts (non-top N charts), then the Export
dialog box displays only the names of the detailed charts.

Steps

1. From the menu bar, click the group or the object that you want to view and for which you want to
export data.
2. Click the name of the view you want to display.
3. From the File menu, select Export.
4. Select and specify the date range, the counters, and the date format.
For advanced views, you can specify the metric data that you want to export.
5. Click Browse, and specify a file name and the location where you want to save the file.
6. Select CSV in the Files of Type field to export the data to CSV format.
7. Click Save.
8. Click Ok.
Result

The application saves the performance view file with a .csv extension to the location that you
specified.
Note: You can view the .csv output file format in Microsoft Excel or Lotus Symphony. You can
also view this file using common text editors, because the data is in plain-text format.

Predefined views of logical and physical objects
You can use predefined views to display performance data of physical and logical storage objects,
such as storage systems, network interfaces, aggregates, volumes, clusters, and Vservers.
Predefined views are available for the following logical and physical objects:
•
•
•

Global groups
Volumes
Processors
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•
•
•
•
•
•
•
•
•
•
•
•
•

Network interfaces
LUNs
Aggregates
Disks
Vservers (clustered environments only)
Clusters (clustered environments only)
Nodes (clustered environments only)
Storage systems (7-Mode environments only)
vFiler units (7-Mode environments only)
Datasets (7-Mode environments only)
Resource pools (7-Mode environments only)
Qtrees (7-Mode environments only)
Targets (7-Mode environments only)

Predefined views at the global or group level
You can display the views at the global or group level to analyze the performance data.
Group Summary View
This view provides a summary for the entire system or group. This view is displayed in either of the
following cases:
•
•

When a user first logs in
When any group is selected

The following panels are available under this view:
•

Top Performance Events
Counters are not applicable for this panel.

•

(7-Mode environments only) Top Storage Systems by Network Throughput
Displays the load_total_mbps counter, which is calculated using the following formula:
load_total_mbps = load_inbound_mbps + load_outbound_mbps
load_inbound_mbps = system:system:net_data_recv + fcp:fcp:fcp_write_data +
iscsi:iscsi:iscsi_write_data
load_outbound_mbps = system:system:net_data_sent + fcp:fcp:fcp_read_data +
iscsi:iscsi:iscsi_read_data

•

(7-Mode environments only) Top Storage Systems by Total Ops
Displays the pa_total_ops counter, which is calculated using the following formula:
system:pa_total_ops = system:system:nfs_ops + system:system:cifs_ops +
system:system:fcp_ops + system:system:iscsi_ops + system:system:http_ops

•

(7-Mode environments only) Top Storage Systems by CPU Utilization
This panel displays the cpu_busy counter.

•

(clustered environments only) Top Vservers by Total Ops
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This panel displays the top Vservers, based on certain performance counters.
•

(clustered environments only) Top Nodes by CPU Utilization
This panel displays the top nodes based on the highest CPU utilization.

Group - Top Objects
This view displays the top five volumes and aggregates in a group. The following panels are
available under this view:
•
•

•
•

Top Volumes by Latency
Displays the avg_latency counter.
Top Volumes by Throughput
Displays the throughput counter, which is calculated using the following formula:
throughput = volume:<instance>:read_data + volume:<instance>:write_data
Top Volumes by Total Ops
Displays the total_ops counter.
Top Aggregates by Total Ops
Displays the total_transfers counter.
Note: The Top N chart view does not display data for counter groups that have sampling intervals
over 5 minutes. However, you can set the global option to a value >= 2 x counter group sampling
interval, to populate the Top N chart.

(7-Mode environments only) Group -Top vFiler units
This view displays the top five vFiler units in a group. The following panels are available under this
view:
•

•

•

Top vFiler units by Disk Data Transferred
Displays the vfiler_data_transferred counter, which is calculated using the following formula:
vfiler_disk_transferred = vfiler:<instance>:vfiler_read_bytes +
vfiler:<instance>:vfiler_write_bytes
Top vFiler units by Network Throughput
Displays the vfiler_nw_throughput counter, which is calculated using the following formula:
vfiler_nw_throughput = vfiler:<instance>:vfiler_net_data_recv +
vfiler:<instance>:vfiler_net_data_sent
Top vFiler units by Total Ops
Displays the vfiler_total_ops counter, which is calculated using the following formula:
vfiler_total_ops = vfiler:<instance>:vfiler_read_ops + vfiler:<instance>:vfiler_write_ops +
vfiler:<instance>:vfiler_misc_ops

Top CPUs
This view displays the top five CPUs in a group. The following panel is available under this view:
•

cpu_busy
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This panel displays the cpu_busy counter.
Top Network Interfaces
This view displays the top five network interfaces in a group. The following panels are available
under this view:
•
•
•
•
•
•

recv_data
Displays the recv_data counter.
recv_errors
Displays the recv_errors counter.
recv_packets
Displays the recv_packets counter.
send_data
Displays the send_data counter.
send_errors
Displays the send_errors counter.
send_packets
Displays the send_packets counter.

Predefined views at the storage system level (7-Mode environments only)
You can display predefined views at the storage system level to analyze the performance data.
Storage system Summary View
This view provides a performance summary for a specific storage system. This is the default view
that is displayed when you select or navigate to a storage system.
The following panels are available under this view:
•

Top Performance Events
Counters are not applicable for this panel.

•

Network Throughput
Displays the load_total_mbps, load_inbound_mbps, and load_outbound_mbps counters, which
are calculated using the following formulae:
load_total_mbps = load_inbound_mbps + load_outbound_mbps
load_inbound_mbps = system:system:net_data_recv + fcp:fcp:fcp_write_data +
iscsi:iscsi:iscsi_write_data
load_outbound_mbps = system:system:net_data_sent + fcp:fcp:fcp_read_data +
iscsi:iscsi:iscsi_read_data

•

Average Latency per Protocol
Displays the nfsv3_avg_op_latency, nfsv4_op_latency, and cifs_latency counters.

•

All Protocol Ops
Displays the following counters:
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•
•
•
•
•
•

system:system:nfs_ops
system:system:cifs_ops
system:system:http_ops
system:system:fcp_ops
system:system:iscsi_ops

CPU Utilization
Displays the cpu_busy counter.

Storage system - Top Logical Objects
This view displays the top five logical objects, such as volumes, qtrees, and LUNs, based on different
counters.
The following panels are available under this view:
•
•
•
•
•

Top Volumes by Ops
Displays the volume:<instance>:total_ops counter.
Top Volumes by Latency
Displays the volume:<instance>:avg_latency counter.
Top LUNs by Ops
Displays the lun:<instance>:total_ops counter.
Top LUNs by Latency
Displays the lun:<instance>:avg_latency counter.
Top Qtrees by Total Ops
Displays the total_ops counter, which is the sum of qtree:<instance>:nfs_ops and
qtree:<instance>:cifs_ops counters.

Storage system - Top Physical Objects
This view displays the top five aggregates and disks in a storage system.
The following panels are available under this view:
•
•

Top Aggregates by Total Ops
Displays the aggregate:<instance>:total_transfers counter.
Top Disks by Disk Busy Percentage
Displays the disk_busy counter.

Storage system - Per Protocol Latencies
This view displays the details of the latencies for different protocols at the storage system level.
The following panels are available under this view:
•
•

Average Latency per Protocol
Displays the nfsv3_avg_op_latency, nfsv4_op_latency, and cifs_latency counters.
NFSv3 Latency by Optype
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•
•
•
•

Displays the nfsv3_avg_op_latency, nfsv3_read_latency, and nfsv3_write_latency counters.
NFSv4 Latency by Optype
Displays the nfsv4_avg_latency counter.
CIFS Latency by Optype
Displays the cifs_latency counter.
FCP Latency by Optype
Displays the fcp_read_latency and fcp_write_latency counters.
iSCSI Latency by Optype
Displays the iscsi_read_latency and iscsi_write_latency counters.

Storage system - Per Protocol Sizes
This view displays the details of the read and write sizes for different protocols at the storage system
level.
The following panels are available under this view:
•
•
•
•

NFSv3 Read Sizes
Displays the nfsv3_read_size_histo counter.
NFSv4 Read Sizes
Displays the nfsv4_read_size_histo counter.
NFSv3 Write Sizes
Displays the nfsv3_write_size_histo counter.
NFSv4 Write Sizes
Displays the nfsv4_write_size_histo counter.

Storage system - Per Protocol Ops
This view displays the details of the total operations for different protocols at the storage system
level.
The following panels are available under this view:
•
•
•
•
•
•

NFSv3 Ops by Optype
Displays the nfsv3_read_ops, nfsv3_write_ops, and nfsv3_ops counters.
NFSv4 Ops by Optype
Displays the nfsv4_read_ops, nfsv4_write_ops, and nfsv4_ops counters.
CIFS Ops by Optype
Displays the system:cifs_ops counter.
FCP Ops by Optype
Displays the fcp_read_ops, fcp_write_ops, and fcp_ops counters.
iSCSI Ops by Optype
Displays the iscsi_read_ops, iscsi_write_ops, and iscsi_ops counters.
All Protocol Ops
Displays the nfs_ops, cifs_ops, http_ops, fcp_ops, and iscsi_ops counters.
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Storage system - Network Throughput
This view displays the details of the network throughput at the storage system level.
The following panels are available under this view:
•

•

•

•

•

Total Throughput
Displays the san_throughput and nas_throughput counters.
This panel also displays the load_total_mbps, load_inbound_mbps, and load_outbound_mbps
counters, which are calculated using the following formulae:
load_total_mbps = load_inbound_mbps + load_outbound_mbps
load_inbound_mbps = system:system:net_data_recv + fcp:fcp:fcp_write_data +
iscsi:iscsi:iscsi_write_data
load_outbound_mbps = system:system:net_data_sent + fcp:fcp:fcp_read_data +
iscsi:iscsi:iscsi_read_data
NAS Throughput
Displays the net_data_recv, net_data_sent, and nas_throughput counters.
The nas_throughput counter is calculated using the following formula:
nas_throughput = net_data_recv + net_data_sent
FCP Throughput
Displays the fcp_write_data, fcp_read_data, and fcp_throughput counters.
The fcp_throughput counter is calculated using the following formula:
fcp_throughput = fcp_write_data + fcp_read_data
iSCSI Throughput
Displays the iscsi_write_data, iscsi_read_data, and iscsi_throughput counters.
The iscsi_throughput counter is calculated using the following formula:
iscsi_throughput = iscsi_write_data + iscsi_read_data
Disk Traffic to User Traffic ratio
Displays the load_write_bytes_ratio and load_read_bytes_ratio counters, which are calculated
using the following formulae:
load_write_bytes_ratio = disk_data_written/load_ inbound_mbps
load_read_bytes_ratio = disk_data_read/load_out bound_mbps

Storage system - Disk Throughput
This view displays the details of the disk throughput. The data is averaged over all the disks in the
storage system.
The following panel is available under this view:
•

Total disk Throughput in Kb/Sec
Displays the disk_data_read, disk_data_written, and disk_throughput counters. The
disk_throughput counter is calculated using the following formula:
disk_throughput = disk_data_read + disk_data_written
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Storage system - Top vFiler units
This view displays the details of the top five vFiler units in the storage system.
The following panels are available under this view:
•
•
•
•

Top vFiler units by CPU Utilization
Displays the vfiler_cpu_busy counter.
Top vFiler units by Network Throughput
Displays the vfiler_nw_throughput counter.
Top vFiler units by Disk Data Transferred
Displays the vfiler_data_transferred counter.
Top vFiler units by Total Ops
Displays the vfiler_total_ops counter.

Top Aggregates
This view displays the details of the top five aggregates in the storage system.
The following panels are available under this view:
•
•
•
•

total_transfers
Displays the aggregate:total_transfers counter.
user_reads
Displays the aggregate:user_reads counter.
cp_reads
Displays the aggregate:cp_reads counter.
user_writes
Displays the aggregate:user_writes counter.

Top LUNs
This view displays the details of the top five LUNs in the storage system.
The following panels are available under this view:
•
•
•

read_ops
Displays the lun:read_ops counter.
other_ops
Displays the lun:other_ops counter.
write_ops
Displays the lun:write_ops counter.

Top Volumes
This view displays the details of the top five volumes in the storage system.
The following panels are available under this view:

90 | Performance Advisor Administration Guide
•
•
•

read_ops
Displays the volume:read_ops counter.
other_ops
Displays the volume:total_ops counter.
write_ops
Displays the volume:write_ops counter.

Predefined views at the vFiler unit level (7-Mode environments only)
You can displays predefined views at the vFiler unit level to analyze the performance data from these
objects.
vFiler unit Summary View
This view provides a summary of the vFiler unit details. The following panels are available under
this view:
•
•
•
•

•
•

Recent events
Counters are not applicable for recent events.
Top Volumes by Latency
Displays the volume:<instance>:avg_latency counter.
Top Volumes by Ops
Displays the volume:<instance>:total_ops counter.
Top Qtrees by Ops
Displays the total_ops counter, which is calculated using the following formula:
total_ops = qtree: <instance>:nfs_ops + qtree: <instance>:cifs_ops
Top LUNs by Ops
Displays the lun:<instance>:total_ops counters.
Top LUNs by Latency
Displays the lun:<instance>:avg_latency counters.

vFiler unit Basic View
This view displays the details of various metrics for the vFiler unit. The following panels are
available under this view:
•
•
•
•
•

vfiler_read_ops
Displays the vfiler_read_ops counter.
vfiler_write_ops
Displays the vfiler_write_ops counter.
vfiler_misc_ops
Displays the vfiler_misc_ops counter.
vfiler_cpu_busy
Displays the vfiler_cpu_busy counter.
vfiler_read_bytes

Views in Performance Advisor | 91

•
•
•

Displays the vfiler_read_bytes counter.
vfiler_write_bytes
Displays the vfiler_write_bytes counter.
vfiler_net_data_recv
Displays the vfiler_net_data_recv counter.
vfiler_net_data_sent
Displays the vfiler_net_data_sent counter.

Predefined views at the processor level
You can use the view at the processor level to display the performance data.
Processor Summary View
This view provides the summary of the processor details.
The following panels are available under this view:
•
•

CPU Utilization
This panel displays the processor_busy counter.
Average CPU Busy per Domain
This panel displays the following counters:
•
•
•
•
•
•
•
•
•
•
•

processor:domain_busy:idle
processor:domain_busy:kahuna
processor:domain_busy:storage
processor:domain_busy:exempt
processor:domain_busy:raid
processor:domain_busy:target
processor:domain_busy:netcache
processor:domain_busy:netcache2
processor:domain_busy:cifs
processor:domain_busy:wafl_exempt
processor:domain_busy:network

Predefined views at the network interface level
You can use predefined views at the network interface level to display performance data.
Network Interface Summary View
This view provides the summary of details about a network interface card.
The following panels are available under this view:
•
•

Top Performance Events
Counters are not applicable for this panel.
Collisions
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•

•

•

•

This panel displays the collisions counter.
Throughput in Pkts/Sec
This panel displays the ifnet:recv_packets, ifnet:send_packets, and ifnet:total_packets counters.
The ifnet:total_packets counter is calculated using the following formula:
ifnet:total_packets = ifnet:recv_packets + ifnet:send_packets
Throughput in Bytes/Sec
This panel displays the ifnet:recv_data, ifnet:send_data, and ifnet:total_data counters.
The ifnet:total_data counter is calculated using the following formula:
ifnet:total_data = ifnet:recv_data + ifnet:send_data
Packet Errors
This panel displays the ifnet:recv_errors, ifnet:send_errors, and ifnet:total_errors counters.
The ifnet:total_errors counter is calculated using the following formula:
ifnet:total_errors = ifnet:recv_errors + ifnet:send_errors
Multicast Packets
This panel displays the ifnet:send_mcasts, ifnet:recv_mcasts, and ifnet:total_mcasts counters.
The ifnet:total_mcasts counter is calculated using the following formula:
ifnet:total_mcasts = ifnet:send_mcasts + ifnet:recv_mcasts

Predefined views at the dataset level (7-Mode environments only)
You can display views at the dataset level to analyze their performance data.
Dataset Summary View
This view displays the top five components in a dataset.
The following panels are available under this view:
•
•
•

Top Volumes by Latency
This panel displays the volume:<instance>:avg_latency counter.
Top Volumes by ops
This panel displays the volume:<instance>:total_ops counter.
Top Qtrees by Ops
This panel displays a counter, which is a sum of the qtree:<instance>:nfs_ops and
qtree:<instance>:cifs_ops counters.

Predefined views at the resource pool level (7-Mode environments only)
You can display predefined views at the resource pool level to analyze the performance data.
Resource Pool Summary View
This view displays the top five objects in a resource pool.
The following panels are available under this view:
•

Top Aggregates by Total Transfers
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•
•

This panel displays the aggregate:<instance>:total_transfers counter.
Top Disks by Disk Busy
This panel displays the disk:<instance>:disk_busy counter.
Top Storage Systems by Ops
This panel displays the pa_total_ops counters.

Predefined views at the volume level
You can use the views at the volume level to display the performance data.
Volume Summary View
This view provides the summary detail of the volume.
The following panels are available under this view:
•
•
•
•

•

•

Top Performance Events
Counters are not applicable for this panel.
Top LUNs by Ops
This panel displays the lun:<instance>:total_ops counter.
Top LUNs by Avg Latency
This panel displays the lun:<instance>:avg_latency counter.
Top Qtrees by Ops (7-Mode environments only)
This panel displays the total_ops counter, which is the sum of qtree:<instance>:nfs_ops and
qtree:<instance>:cifs_ops.
Overall Latency by Optype
This panel displays the following counters:
• volume:<instance>:avg_latency
• volume:<instance>:read_latency
• volume:<instance>:write_latency
• volume:<instance>:other_latency
Overall Iops by Optype
This panel displays the following counters:
•
•
•
•

volume:<volume_name>:read_ops
volume:<volume_name>:write_ops
volume:<volume_name>:other_ops
volume:<volume_name>:total_ops

Volume Latency View
This view displays details of the latencies for different protocols for the volume.
The following panels are available under this view:
•

Overall Latency by Optype
This panel displays the following counters:
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•

•

•

• volume:<instance>:avg_latency
• volume:<instance>:read_latency
• volume:<instance>:write_latency
• volume:<instance>:other_latency
NFS Latency by Optype
This panel displays the following counters:
• volume:<instance>:nfs_read_latency
• volume:<instance>:nfs_write_latency
• volume:<instance>:nfs_other_latency
• volume:<instance>:nfs_latency
CIFS Latency by Optype
This panel displays the following counters:
• volume:<instance>:cifs_read_latency
• volume:<instance>:cifs_write_latency
• volume:<instance>:cifs_other_latency
• volume:<instance>:cifs_latency
SAN Latency by Optype
This panel displays the following counters:
•
•
•
•

volume:<instance>:san_read_latency
volume:<instance>:san_write_latency
volume:<instance>:san_other_latency
volume:<instance>:san_latency

Volume IOPs View
This view displays the details of the IOPS for different protocols at the storage system level.
The following panels are available under this view:
•

•

Overall Iops by Optype
This panel displays the following counters:
• volume:<volume_name>:read_ops
• volume:<volume_name>:write_ops
• volume:<volume_name>:other_ops
• volume:<volume_name>:total_ops
NFS Iops by Optype
This panel displays the following counters:
•
•
•
•

volume:<volume_name>:nfs_read_ops
volume:<volume_name>:nfs_write_ops
volume:<volume_name>:nfs_other_ops
volume:<volume_name>:nfs_ops
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•

•

•

CIFS Iops by Optype
This panel displays the following counters:
• volume:<volume_name>:cifs_read_ops
• volume:<volume_name>:cifs_write_ops
• volume:<volume_name>:cifs_other_ops
• volume:<volume_name>:cifs_ops
SAN Iops by Optype
This panel displays the following counters:
• volume:<volume_name>:san_read_ops
• volume:<volume_name>:san_write_ops
• volume:<volume_name>:san_other_ops
• volume:<volume_name>:san_ops
User Ops v/s Sys Ops
This panel displays the following counters:
•
•

volume_user_ops
volume_sys_ops

The above counters are calculated using the following formula:
•

•

volume_user_ops = sum(volume:<instance>:nfs_read_ops + nfs_write_ops + nfs_other_ops +
cifs_read_ops + cifs_write_ops + cifs_other_ops + san_read_ops + san_write_ops +
san_other_ops)
• volume_sys_ops = volume:<instance>:total_ops - volume_user_ops
FlexCache Iops by Optype
The above counters are calculated using the following formula:
•
•
•

volume:<volume_name>:flexcache_read_ops
volume:<volume_name>:flexcache_write_ops
volume:<volume_name>:flexcache_other_ops

Predefined views at the qtree level (7-Mode environments only)
You can display predefined views at the qtree level to analyze their performance data.
Qtree Summary View
This view provides the summary details of the qtree.
The following panels are available under this view:
•
•

Top Performance Events
Counters are not applicable for this panel.
Throughput in Ops
This panel displays the following counters:
•

qtree:<instance>:nfs_ops
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•
•

qtree:<instance>:cifs_ops
qtree:<instance>:internal_ops

Predefined views at the LUN level
You can use the views at the LUN level to display the performance data.
LUN Summary View
This view provides the summary of LUN details.
The following panels are available under this view:
•
•

•

•

Top Performance Events
Counters are not applicable for this panel.
Throughput in Ops
This panel displays the following counters:
• lun:<instance>:read_ops
• lun:<instance>:write_ops
• lun:<instance>:other_ops
• lun:<instance>:total_ops
Throughput in Bps
This panel displays the following counters:
• lun:<instance>:read_data
• lun:<instance>:write_data
• throughput
Average Latency
This panel displays the lun:<instance>:avg_latency counter.

LUN Alignment View
This view provides the alignment details of the LUN.
The following panels are available under this view:
•

•

•

Aligned WAFL Ops
This panel displays the following counters:
• read_align_histo
• write_align_histo
Unaligned WAFL Ops
This panel displays the following counters:
• unaligned_reads
• unaligned_writes
Partial blocks
This panel displays the following counters:
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•
•

read_partial_blocks
write_partial_blocks

Predefined views at the aggregate level
You can view the details of the aggregate to understand the performance data.
Aggregate Summary View
This view provides the summary of aggregate details.
The following panels are available under this view:
•
•
•

Top Performance Events
Counters are not applicable for this panel.
Top Disks by disk_busy
This panel displays the disk:<instance>:disk_busy counter.
Throughput in Blocks/Sec
This panel displays the following counters:
•
•
•
•

aggregate:<instance>:user_read_blocks
aggregate:<instance>:user_write_blocks
aggregate:<instance>:cp_read_blocks
total_transfers

Predefined views at the disk level
You can use the views at the disk level to display the performance data.
Disk Summary view
This view provides the summary of the disk details.
The following panels are available under this view:
•
•

•

Top Performance Events
Counters are not applicable for this panel.
Throughput in Ops
This panel displays the following counters:
• disk:<instance>:total_transfers
• disk:<instance>:user_reads
• disk:<instance>:user_writes
• disk:<instance>:cp_reads
Throughput in Blocks
This panel displays the following counters:
•
•

disk:<instance>:user_read_blocks
disk:<instance>:user_write_blocks
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•

•

•
•

• disk:<instance>:cp_read_blocks
• throughput
Disk Latency
This panel displays the following counters:
• disk:<instance>:user_read_latency
• disk:<instance>:user_write_latency
• disk:<instance>:cp_read_latency
Disk Chain Info
This panel displays the following counters:
• disk:<instance>:user_read_chain
• disk:<instance>:user_write_chain
• disk:<instance>:cp_read_chain
Disk Util
This panel displays the disk:<instance>:disk_busy counter.
Guaranteed Ops
This panel displays the guaranteed_reads and guaranteed_writes counters.

Predefined view at the target level (7-Mode environments only)
You can display a view at the target level to interpret the performance data.
Target Basic
This view provides the basic details at the target level.
The following panels are available under this view:
•
•
•
•

read_ops
Displays the read_ops counter.
write_ops
Displays the write_ops counter.
other_ops
Displays the other_ops counter.
queue_full
Displays the queue_full counter.

Predefined views at the cluster level (clustered environments only)
You can display the views at the cluster level to analyze the performance data.
Cluster Summary View
This view provides a summary for a specific cluster. This is the default view that is displayed when
you select or navigate to a cluster.
The following panels are available under this view:
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•

Top Performance Events
Counters are not applicable for this panel.

•

Top Vservers by Total Ops
Displays the total_ops counter.

•

Top Nodes by CPU Busy
Displays the cpu_busy counter.

•

Top Aggregates by total_transfers
Displays the total_transfers counter.

•

Top Volumes by Latency
Displays the avg_latency counter.

Predefined views at the Vserver level (clustered environments only)
You can display views at the Vserver level to analyze the performance data.
Vserver Summary View
This view provides a summary of a specific Vserver. This is the default view that is displayed when
you select or navigate to a Vserver. The following panels are available under this view:
•

Top Performance Events
Counters are not applicable for this panel.

•

Vservers by Total Ops
Displays the total_ops counter.

•

Vserver - All Protocol Ops
Displays the cifs_ops, iscsi_pa_total_ops and fcp_pa_total_ops counters.

Vservers - Top Volumes
This view displays the top five volumes in the Vserver. The following panels are available under this
view:
•

Top Volumes by Total Ops
Displays the total_ops counter.

•

Top Volumes by Aggregate Latency
Displays the avg_latency counter.

•

Top Volumes by Read Ops
Displays the read_ops counter.

•

Top Volumes by Write Ops
Displays the write_ops counter.
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Vservers - Top LUNs
This view displays the top five LUNs in the Vserver. The following panels are available under this
view:
•

Top LUNs by Total Ops
Displays the total_ops counter.

•

Top LUNs by Aggregate Latency
Displays the avg_latency counter.

•

Top LUNs by Read Ops
Displays the read_ops counter.

•

Top LUNs by Write Ops
Displays the write_ops counter.

Vserver CIFS View
This view provides a summary of the CIFS performance of the Vserver. The following panels are
available under this view:
•

Vserver CIFS Ops
Displays the cifs_ops, cifs_read_ops, cifs_write_ops, cifs_read_latency and the
cifs_write_latency counters.

•

Vserver CIFS Latencies
Displays the cifs_latency counter.

Vserver FCP View
This view provides a summary of the FCP performance of the Vserver. The following panel is
available under this view:
•

Vserver FCP Ops
Displays the fcp_read_ops and fcp_write_ops counters.

Vserver iSCSI View
This view provides a summary of the iSCSI performance of the Vserver. The following panel is
available under this view:
•

Vserver iSCSI Ops
Displays the iscsi_read_ops and iscsi_write_ops counters.
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Predefined views at the node level (clustered environments only)
You can display the views at the node level to analyze the performance data of nodes.
Node Summary View
This view gives a summary for a specific node. This is the default view that is displayed when a user
selects or navigates to a node.
The following panels are available under this view:
•

Top Performance Events
Counters are not applicable for this panel.

•

Throughput
Displays the net_data_sent, net_data_recv, disk_data_read, and the disk_data_written counters.

•

Volume Throughput
Displays the read_data and write_data counters.

•

Volume Latencies
Displays the avg_latency counter.

•

CPU Utilization
Displays the cpu_busy counter.

Node Per Protocol Ops
This view displays charts related to the network throughput of the specified node.
The following panels are available under this view:
•

NFSv3 ops
Displays the nfsv3_read_ops and nfsv3_write_ops counters.

•

CIFS ops
Displays the cifs_read_ops and cifs_write_ops counters.

•

FCP ops
Displays the read_ops and write_ops counters.

Node - Top Volumes
This view displays the top five volumes in the node. This panel displays the following counters:
•
•
•

read_ops
Displays the read_ops counter.
write_ops
Displays the write_ops counter.
total_ops
Displays the total_ops counter.
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Node - Top Physical Objects
This view displays the top five physical objects in the node. The following panels are available under
this view:
•

Top Aggregates by Total Ops
Displays the total_transfers counter.

•

Top Disks by Disk Busy Percentage
Displays the disk_busy counter.

Node - Top Logical Objects
This view shows the top five logical objects in the node. The following panels are available under
this view:
•

Top LUNs by Latency
Displays the avg_latency counter.

•

Top LUNs by Ops
Displays the total_ops counter.

•

Top Volumes by Latency
Displays the avg_latency counter.

•

Top Volumes by Ops
Displays the total_ops counter.

Node - Top Aggregates
This view displays the top five aggregates in the node. This panel displays the following counters:
•
•
•
•

total_transfers
Displays the total_transfers counter.
cp_reads
Displays the cp_reads counter.
user_reads
Displays the user_reads counter.
user_writes
Displays the user_writes counter.

Node - Top LUNs
This view displays the top five LUNs in the node. This panel displays the following counters:
•
•

read_ops
Displays the read_ops counter.
write_ops
Displays the write_ops counter.
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•

other_ops
Displays the other_ops counter.
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Alarms, hosts, and thresholds
You can use alarms, list of hosts, and thresholds in Performance Advisor to monitor datasets and
resources, edit login credentials on hosts, and identify potential performance issues of storage
systems.

What alarms are
Alarms are configured notifications that are sent whenever a specific event or an event of a specific
severity type occurs, not necessarily related to a specific user. Alarms are used to monitor and
manage datasets and resources, as a whole.
Alarms are not the events themselves, only the notification of events. Alarms are not the same as user
alerts. For a complete description of user alerts, see the Operations Manager Administration Guide.
You can create alarms for any storage system for which you want automatic notification of events.
You can use the Set Up Alarms window to add, monitor, and edit alarms.

List of alarm management tasks
You can respond to, view, edit, test, disable, enable, add, or delete data performance alarms.
Alarm management
tasks

This list describes the alarm management tasks that you perform most
often.

Responding to
alarms

When you receive an alarm, you should acknowledge the event and resolve
the condition that triggered the alarm. If the repeat notification feature is
enabled and the alarm condition persists, you continue to receive
notifications until you acknowledge the event.

Viewing the list of
alarms

View the list of all currently configured data protection alarms when you
want an overview of what is configured for any selected group. You can
control the sort order of any column in the list. You can also control which
alarms are displayed by filtering the information in any column in the list.

View the configuration details of any selected alarm when you want to
Viewing the
configuration values know specific information or you are considering modifying the
configuration.
for any selected
alarm
Editing the alarm

Modify the configuration of an alarm when you need to accommodate
changes in the environment. For example, you might need to update a
recipient e-mail address, add another recipient pager address, add a
recipient script name, or change the hours during which the alarm is active.
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Testing an alarm

Test a new or modified alarm by having Protection Manager send a test
message to all the recipients configured for the selected alarm.

Disabling or
enabling an alarm

Disable an alarm when you need to stop its functioning for a while but want
to retain the alarm configuration. For example, if you have an alarm
configured for the SnapVault Backup Failed event and you scheduled
downtime for maintenance on that host, you might disable the alarm during
the planned downtime. When the host is up again, you can enable the
alarm.

Adding an alarm

Configure a new alarm when you want notification of a specific event or
any event of a specific severity type for a group.

Deleting an alarm

Delete an alarm only when you are sure that you no longer need notification
of the event or severity type occurring for the group.

Managing and monitoring alarms
You can use the Alarms window to perform all the alarm monitoring and managing tasks. When
responding to an alarm, you can use the Events window to view details about the event.

Monitoring alarms
You can view a list of all the alarms configured for your application and capabilities.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. Depending on the alarms you want to view, perform one of the following actions:
•
•

For protection, provisioning, or disaster recovery alarms, from the menu bar,
click Notifications > Alarms.
For Performance Advisor alarms, from the menu bar, click Set Up > Alarms.

2. Optional: You can customize the Alarms window in one of the following ways:
•
•

•

Select an alarm to see the configured property values for that alarm.
in a column header to control which alarm entries you want displayed.
Click
The color of the column header changes to indicate that you are filtering the entries in that
column.
Some column filters display a drop-down list to select from and other column filters display a
search field in which you can enter text to select.
Click the sort arrows in a column header to change the sort order of the entries in that column.
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•
•

Click
in the upper-right corner of the list to select which columns are displayed.
Drag the bottom of the alarms list area up or down to resize that area.

Creating alarms
You can create alarms by using the Add Alarm wizard.
Steps

1. Click Set Up > Thresholds.
2. Click the Summary tab.
3. Select the threshold.
4. Click Add Alarm.
5. Complete the Add Alarm wizard.

Editing alarms
You can change the configuration of an existing alarm.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. For protection, provisioning, or disaster recovery alarms, from the menu bar, click Notifications
> Alarms. For Performance Advisor alarms, from the menu bar, click Set Up > Alarms.
2. Select an alarm in the Alarms window and click Edit.
3. Use the tabs in the Properties sheet (Group, Event Type, Recipient, and Details) to change the
configured property values.
4. Click Apply to commit your changes.
5. Click OK to close the Properties sheet.
The new configuration is immediately activated and displayed in the Alarms list.
6. Verify your changes by viewing the results that are displayed in the Alarms window.
You can select an alarm to view the current property values for that alarm.
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Testing alarms
You can test an alarm to check its configuration, after creating or editing the alarm.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. For protection, provisioning, or disaster recovery alarms, from the menu bar, click Notifications
> Alarms. For Performance Advisor alarms, from the menu bar, click Set Up > Alarms.
2. Select an alarm and click Test.
You can select any alarm regardless of whether it is enabled or disabled.
3. Click OK in the Confirm Alarm(s) Test window to begin the test.
A test event notification is sent to each configured recipient. If a script is configured, the test
notification runs the script.
4. Verify the alarm recipient configuration by checking that each recipient received a test message.
If a script recipient is configured, check that the script was successfully started.
After you finish

You can modify any of the alarm properties from the Alarms window.

Enabling or disabling alarms
You can disable an alarm when you need to temporarily stop its functioning and enable it when you
want it to start functioning again.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
About this task

Disabling an alarm enables you to retain the alarm configuration while its functioning is temporarily
stopped. For example, if you have an alarm that is configured for the SnapVault Backup Failed event
and you scheduled down time for maintenance on a host that is in the resource pool for the group
associated with that alarm, you might disable the alarm during the planned down time. When the host
is up again, you can enable the alarm to resume its functioning.
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Steps

1. For protection, provisioning, or disaster recovery alarms, from the menu bar, click Notifications
> Alarms. For Performance Advisor alarms, from the menu bar, click Set Up > Alarms.
2. In the alarms list, locate the entry for the alarm you want to enable or disable.
3. Clear the Enabled check box to disable the associated alarm, or select the Enabled check box to
enable it.
The alarm is immediately disabled or enabled.
4. Verify your change by viewing the results that are displayed in the Alarms window.

Adding alarms
You can add an alarm when you want immediate notification that a specified event or event class or
event of a specified severity level occurred.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Have the following information available to complete this task:
•
•
•
•
•

The resource group with which you want the alarm associated.
The event name, event class, or severity type that triggers the alarm.
Who and what you want the event notification sent to.
The time period during which the alarm is active.
Whether you want the event notification repeated until the event is acknowledged and how often
the notification should be repeated.

Steps

1. For protection, provisioning, or disaster recovery alarms, from the menu bar, click Notifications
> Alarms. For Performance Advisor alarms, from the menu bar, click the Set Up Alarms
window.
2. Click Add to start the Add Alarm wizard.
3. On each page of the wizard, enter the appropriate information.
4. Click Finish to commit your choices and close the Add Alarm wizard.
5. Verify the creation and configuration of the alarm by viewing the results that are displayed in the
Alarms window.
After you finish

You can edit the alarm properties from the Alarms window.
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Deleting alarms
You can delete an alarm when you no longer need immediate notification of an event or severity
type.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
Steps

1. For protection, provisioning, and disaster recovery alarms, from the menu bar, click Notifications
> Alarms. For Performance Advisor alarms, from the menu bar, click Set Up > Alarms.
2. Select one or more alarms in the Alarms window and click Delete.
3. Click OK in the Confirm Alarm(s) Delete dialog box to delete the selected alarms.
The alarm configurations are deleted and the alarms are removed from the Alarms list.
4. Verify your deletion by viewing the results that are displayed in the Alarms window.

Responding to alarms
When you receive an alarm, you can acknowledge the event and resolve the condition that triggered
the alarm.
Before you begin

You must be authorized to perform all the steps of this task; your RBAC administrator can confirm
your authorization in advance.
About this task

If the repeat notification feature is not enabled, you receive the event notification only once. If the
repeat notification feature is enabled and the alarm condition persists, you continue to receive
notifications until you acknowledge the event.
Steps

1. For protection, provisioning, and disaster recovery alarms, from the menu bar, click Notifications
> Events. For Performance Advisor alarms, from the menu bar, click Monitor > Events.
2. Select an event whose details you want to view.
3. Click Acknowledge to indicate that you are taking responsibility for managing that event.
4. Click Yes in the Acknowledge Events dialog box to acknowledge the selected event.
Your user name and the time are entered in the Events list for the selected event.
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5. Find the cause of the event and take corrective action.

Display of storage systems by using Performance Advisor
You can use Performance Advisor to view a list of the hosts discovered by the DataFabric Manager
server. You can set, modify, and check the login credentials on hosts by using the application.
The following conditions should be set for the DataFabric Manager server to start collecting data
from the discovered storage systems:
•

The login credentials for the storage system must be set.

•

The transport protocol must be set for the storage system discovered by the DataFabric Manager
server.
The performance data collection option must be set.

•

If you are using a version of NetApp Management Console prior to version 2.1, then you must use
the DataFabric Manager server to set the credentials. If you are using a version of NetApp
Management Console later than version 2.1, then you must use the NetApp Management Console to
set the credentials.

Host table field descriptions
You can select a host to display the host name, IP address, host status, user name, password, host
transport, and other Performance Advisor details.
Field

Description

Name

The name of the host

Node Name

(clustered environments only) The name of the host

IP address

The IP address of the host

Cluster Management
IP address

(clustered environments only) The IP address of the cluster

Node Management IP
address

(clustered environments only) The IP address of the node

Perf Status

The status of the performance

Status

The status of the host

Login Credentials

Information that the user is authenticated on the host

Perf Advisor Transport The protocol used for communication
Data Collection Status

The status of data collection in the host

Max Projected Space

Maximum space that is available in the host
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Field

Description

Used Space

Space that is used in the host

Percentage of Used
Space

Space, in percentage, that is used in the host

Host Transport

The protocol used for communication

Editing host credentials
You can set, edit, or verify the host credentials in storage systems and clusters by using Performance
Advisor.
Steps

1. From the menu, perform the appropriate action:
For...

Do this...

Storage systems (7-Mode environments only)

Click Set Up > Storage Systems.

Clusters (clustered environments only)

Click Set Up > Clusters.

2. Select a host, and click Edit.
3. In the Host Properties window, enter the user name and password in the Login Credentials
section.
4. Select the Use hosts.equiv check box to use the hosts.equiv option.
For more information about the hosts.equiv option, see the OnCommand Unified Manager
Operations Manager Administration Guide.
5. If you want to collect data from this specific host, select the Enable Data Collection check box.
6. Select the transport protocol for data collection from the Perf Advisor Transport list.
You can select one of the following options for the transport protocol: HTTPS Ok, HTTP Only,
or Global Default. The default protocol setting is HTTP.
7. Click Apply, and then click Ok.
Result

The credentials are updated in the DataFabric Manager server database.
Related information

OnCommand Unified Manager Operations Manager Administration Guide: support.netapp.com/
documentation/productsatoz/index.html
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Configuration of data collection
You can configure data collection in 7-Mode environments only by enabling or disabling counters
through the Data Collection Configuration Wizard. You can also change the sample rate and
retention period for counter groups by using the wizard. The default sample rate for data collection in
7-Mode environments is 1 minute.
For clustered environments, you can only view the default data collection configuration, which is
system generated. The default sample rate for data collection in clustered environments is 5 minutes.
You cannot modify the sample rate.
Note: Performance Advisor does not support data collection for unmapped LUNs.

Copying the data collection configuration (7-Mode environments only)
You can copy the configuration related to the performance data collection of one storage system and
apply it to one or more storage systems for easy management and administration.
Before you begin

The Data Collection Status icon in the hosts list must be green for the storage system.
Steps

1. Click Set Up > Storage Systems.
2. Click Data Collection > Copy, and then click Next.
3. Select one or more available storage systems.
Note: If you select more than 10 storage systems, the NetApp Management Console might stop

responding.
4. Click Next, and then click Finish.

Effect of increasing sample rates (7-Mode environments only)
You can lose the historical data if you increase the sample rates for data collection.
Some space is reclaimed on the DataFabric Manager server when data samples are collected in even
numbers such as 2, 4, and 6. For example, if you have 100 data samples collected for a week, when
you double the sample rate, the number of data samples collected are halved to 50. Every second
sample from the collection is deleted.
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Setting retention periods and sample rates (7-Mode environments only)
You can reset sample rates to set the frequency with which performance data should be collected, and
retention periods to set how long the data should be retained in the system by using the Data
Collection Configuration wizard. You can start the wizard from the Set Up Storage Systems window.
About this task
Attention: If you decrease the retention period immediately after increasing the sample rate, there

might be a data loss.
Steps

1. Click Set Up > Storage Systems.
2. Select the storage system for which you want to set a retention period and sample rate.
3. Click Data Collection > Edit.
4. Set the retention period and sample rate in the Data Collection Configuration wizard.

How thresholds work
You can use thresholds to determine the point at which Performance Advisor should generate an
event or alarm to identify potential issues that might impact the performance of storage objects.
This is dependent on the threshold interval and the counter value that you set. If you set a threshold
on a counter such as the average latency counter on any volume, then an event is generated when the
threshold breaches a particular counter value for an interval.
When you apply a threshold to a parent object, and if the threshold uses a counter associated with a
child object, then the threshold is applied to all the child objects. If the parent-child object
relationship is broken, the thresholds inherited from the parent no longer apply to the child.
You can apply thresholds for two or more counters on one or more objects. The threshold interval for
all the thresholds in a combination remains the same. For example, you can set thresholds for the
avg_latency and total_ops counters within a volume. Events are generated only when all the
thresholds are breached.
If you apply thresholds to objects with a parent-child relationship, such as aggregate and disk objects,
an event is generated at the child object level. For example, you can set threshold values for the
cp_read_blocks counter on an aggregate and the disk_busy counter on a disk. The event is generated
on the object that is lowest in the hierarchy.
In clustered environments, every cluster node contains a volume called vol0 that stores the
configuration information of the node. This volume does not belong to a Vserver and therefore,
cannot be used to provide data. Performance Advisor does not manage these volumes.
You cannot apply thresholds to the following combination of cluster objects:
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•
•
•
•
•

Disks and LUNs
Disks and volumes
Vservers and aggregates
Vservers and disks
Vservers and ifnet (interface)

You cannot apply thresholds to the following combination of 7-Mode objects:
•
•
•
•
•
•

Disks and LUNs
Disks and qtrees
Disks and volumes
Network interfaces and targets
Aggregates and vFiler units
vFiler units and disks

You can set thresholds on counters specific to objects such as targets, interfaces, and disks. However,
you cannot set thresholds on processors, RAID groups, and plexes.

What resource properties are
Resource properties are conditions such as disk type, disk roles, system models, and system versions
that should be met while applying thresholds on the objects. By applying resource properties, you can
generate events only when a threshold breach occurs on a particular model and a version of the
storage system.
Rule-based thresholds are applied to groups comprising storage systems. When a new storage system
is added to the group, the threshold applied to the group must also be applied to the new member.
The threshold settings are automatically refreshed after 15 min. However, you can refresh the
settings immediately using the dfm perf threshold refresh command.
For example, you can set a threshold only on 3170 in a group by setting the filter details. However,
the threshold must be rule-based.
You can use the Add Threshold Wizard to set the filter details for a threshold. You can display the
filter property and the corresponding value by selecting a value in the list.

Viewing threshold values
You can view existing threshold values by using the Summary tab.
Steps

1. Click Set Up > Thresholds.
2. Click the Summary tab.
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When to use thresholds in combination
You might not want to receive alerts for every small activity on an object. In such cases, you should
consider applying thresholds in combination by creating a rule on more than one counter for objects
in storage systems.
For example, if you set thresholds on the avg_latency counter for all LUNs in a storage system, you
might receive alarms from LUNs which are hardly used. To stop generating such events, you must
apply thresholds on more than one counter. In this case, you can create a rule to generate alerts only
when the total_ops counter and the avg_latency counter breach the threshold values.

What the Details tab is
The Details tab displays a page with the object tree on the left pane and the list of counters with the
threshold values on the right pane.
The objects in the object tree are of two types:
•
•

Logical
Physical

Adding thresholds
You can add thresholds for the performance counters on storage systems using the Set Up Thresholds
window. Alternatively, you can right-click the object in the logical or physical hierarchy to add
thresholds.
Steps

1. Click Set Up > Thresholds.
2. Click the Summary tab.
3. Click Add.
You cannot add thresholds on the objects whose storage systems do not have valid credentials.
4. Complete the Add Thresholds wizard by entering the threshold values you want to set for your
performance counters.

Editing thresholds by using the Summary tab
You can edit the type, value, and interval of thresholds and event names by using the Summary tab in
the Set Up Thresholds window. However, you cannot edit thresholds that are based on threshold
templates.
Steps

1. Click Set Up > Thresholds.
2. Click the Summary tab.
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3. Modify the threshold by choosing one of the following actions:
•
•

Select the threshold, and click Edit.
Right-click the threshold, and click Edit.

4. Edit the threshold details.
5. Click Apply.
6. Click Ok.

Editing thresholds using charts
You can modify the threshold value and the threshold interval on charts.
Steps

1. Select Show Threshold on the chart.
2. Drag the dotted line.
However, you cannot edit thresholds if they are based on threshold templates or are set on parent
objects. In such cases, you cannot drag the line.
3. Edit the threshold details.
4. Click Apply.
5. Click OK.

Editing thresholds using the Details tab
You can modify the threshold value and the threshold interval for the selected threshold using the
Details tab in the Set Up Thresholds window.
About this task
Note: You cannot edit thresholds based on threshold templates or thresholds set on parent objects.
Steps

1. Click Set Up > Thresholds.
2. Click the Details tab.
3. Select the object.
4. Click the threshold in the Existing threshold box.
5. Edit the threshold value.
6. Edit the threshold interval.
7. Click Apply.
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8. Click OK.

Deleting thresholds
You can delete thresholds by using the Summary tab in the Set Up Thresholds window.
Steps

1. Click Set Up > Thresholds.
2. Click the Summary tab.
3. Delete one or more thresholds by choosing one of the following actions:
•
•

Select the thresholds and click Delete.
Select the thresholds, and then right-click and click Delete.

4. Click Ok.

What a threshold template is (7-Mode environments only)
A threshold template is a set of thresholds that you can apply to one or more objects in a storage
system. Using threshold templates, you can group multiple thresholds into a single unit and associate
multiple objects to these thresholds.
You can assign an object to a template only if there is at least one applicable threshold in the
template. For example, you can assign a volume to a template with two thresholds: one set on
system:cpu_busy and the other set on volume:total_ops. You cannot assign a volume object if the
volume threshold is not present in the template.
You might want to generate a set of events for an object when it exceeds its counter thresholds. In
such cases, you should consider creating a threshold template, which defines a set of thresholds, and
apply the template to the object. For example, you can create a threshold template that contains a
threshold for the cp_writes counter greater than 10 per second for 5 minutes. You can apply these
values in a template to objects to generate events.
You can create and view templates by using the Set Up Threshold Templates window, which has two
sections. The section on the top displays the template table, and the section on the bottom lists the
events, counters, and resource properties. The object tab in the bottom-half of the page displays the
objects that are applied to the selected template.
When to use threshold templates (7-Mode environments only)
You might want to use threshold templates to modify a threshold that is applied on more than one
object. You can also use the templates to add or remove thresholds on objects.
For example, if you want to change the threshold limit from 90% to 80% for a threshold that is
applied on the system:cpu_busy counter for 10 storage systems, you can modify all the 10 thresholds
by using threshold templates. Threshold templates enable you to modify the threshold on all the
storage systems with just one change in the template.
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If you want to create 10 identical thresholds for 10 storage systems, you can apply a template to all
the storage systems to create as many thresholds. Similarly, you can remove the objects from an
existing threshold by using the threshold templates.
Creating threshold templates (7-Mode environments only)
You can create threshold templates by using the Add Threshold Template wizard to apply threshold
settings to a specific storage object.
About this task
Note: You can add a threshold template by using the Set Up Thresholds window.
Steps

1. Click Set Up > Threshold Templates.
2. Click Add.
3. Follow the prompts in the wizard to create the threshold template.
Editing threshold templates (7-Mode environments only)
You can add, edit, or delete existing threshold templates by using the Set Up Threshold Templates
window.
Steps

1. Click Set Up > Threshold Templates.
2. Click Edit.
3. Click Threshold Details to add, edit, or delete the thresholds in the template.
4. Click Ok.
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Glossary
associated view

A performance view available for an object. An associated view can be a
predefined view or a custom view. Predefined views are associated to an object
based on the object type. Custom views can be associated to an object by the
user.

counter

A statistical measurement of activity on a storage system or storage subsystem
that is provided by Data ONTAP.

custom views

User-defined views that include metrics from multiple performance counters.

dataset

A collection of storage sets, along with configuration information, associated
with data. The storage sets associated with a dataset include a primary storage
set used to export data to clients, and the set of replicas and archives that exist
on other storage sets. Datasets represent exportable user data.

hierarchical
groups

The customizable grouping of storage systems, clusters, and nodes whose
performance can be monitored and displayed through Performance Advisor.
All systems that are monitored by the DataFabric Manager server and whose
performance can be monitored by Performance Advisor are displayed in the
Groups browser panel of Performance Advisor.

historical data

Data that is archived by the performance-monitoring server on the DataFabric
Manager server. All the data that is included in the Performance Advisor
default views is also archived as historical data.
Historical data is accessible to any Performance Advisor that can connect to the
workstation. Historical data is collected on an ongoing basis, independent of
whether a client has the associated performance view open. Historical data can
be used for diagnosing past performance problems or for short-term trend
analysis.

hosting storage
system

The physical storage system on which one or more vFiler units are configured.
Some counters that Performance Advisor tracks apply to both storage systems
and vFiler units. Other counters (for example, CPU usage) apply only to
storage systems and the associated host of a vFiler unit. The hosting storage
system is also referred to as the vFiler host.

logical objects

Object types that represent storage systems, such as volumes, qtrees, LUNs,
vFiler units, Vservers, and datasets.

logical hierarchy The hierarchy that displays the logical objects.
lower threshold

The type of threshold that is set for an event generation when the counter value
falls and remains below the lower threshold value for longer than the Threshold
Interval specified.
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managed object

Any object that has an identity and a name in the DataFabric Manager server
object table. A managed object is an object that is contained within a
DataFabric Manager server group. Volumes, aggregates, qtrees, and LUNs are
examples of managed objects.

NetApp
Management
Console

The client platform for the Java-based NetApp Manageability Software
applications. NetApp Management Console runs on a Windows or Linux
workstation, separate from the system on which the DataFabric Manager server
is installed.

object

Typically there is an object associated with each hardware or software
subsystem within Data ONTAP. Examples of hardware objects are the
processor, disk, NVRAM, and networking card objects. FCP, iSCSI, CIFS, and
NFS are examples of software protocol objects. WAFL, RAID, and target are
examples of internal objects that are specific to Data ONTAP.
Virtual objects, such as the system object, capture key statistics across all the
other objects in one single place. Examples of system objects are
avg_processor_busy, nfs_ops, cifs_ops, and net_data_recv.

Performance
Advisor

The Performance Advisor component that is installed on the NetApp
Management Console platform, which enables you to monitor the performance
of storage systems and clusters.
The user interface of Performance Advisor that contains only performancemonitoring information. This Performance Advisor interface is distinct from
Operations Manager, which contains other DataFabric Manager server
information.

performancemonitoring
server

The Performance Advisor component that is enabled on the DataFabric
Manager server to collect and archive performance data at regular intervals
from the monitored storage systems and clusters. Performance Advisor gathers
sets of data that the performance-monitoring server has collected to generate its
graphical charts and views.

performance
view

A collection of one or more counters accessible through Performance Advisor
for a group of storage systems or subsystems through one or more charts.
Performance Advisor displays predefined views that are built in to the system,
and custom views.

physical objects

Object types that represent the physical resources in a storage system, such as
disks, aggregates, memory, network interfaces, resource pools, and RAID
groups.

physical
hierarchy

The hierarchy that displays the physical objects and instances.

real-time data

Data that is collected by Performance Advisor for display but is not stored.
Real-time data is collected only as long as the performance view window

Glossary | 121
displaying it is open on Performance Advisor. Real-time data is accessible only
to the client by which it is retrieved.
Real-time data is suitable for diagnosing immediate performance issues.
resource pool

A managed object in the DataFabric Manager server, containing storage
provisioning resources such as storage systems, aggregates, and spare disks.

retention period

The amount of previously collected data for a counter that is accessible to the
user. You can set the retention period based on units of a minute, hour, day,
week, month, or year.

sample rate

The rate at which data is collected for a counter. You can set the sample rate
based on units of a minute.

storage set

Containers that are used for delegation, replication, and in some cases,
substorage provisioning. A storage set contains a group of volumes, while a
volume should be in at most one storage set.

storage system

An appliance that is attached to a computer network and is used for data
storage. FAS appliances and NearStore systems are examples of storage
systems.

templates and
predefined
templates

A template is a view definition that applies to object instances known to
Performance Advisor.

threshold
interval

The amount of time, in seconds, for which an event generation is suppressed
before Performance Advisor decides that a counter has crossed a specified
threshold and an event has to be generated. The same interval is also used to
generate a normal event.

unmanaged
object

Objects apart from the managed objects belong to the class of unmanaged
objects. An unmanaged object does not have a unique identity in the
DataFabric Manager server table.

upper threshold

The type of threshold set for an event generation when the counter value
exceeds and remains above the higher threshold value for longer than the
specified Threshold Interval.

vFiler unit

One or more virtual storage systems that can be configured on a single physical
storage system licensed for the MultiStore feature.

view

A collection of related panels represented together and displayed by the
Performance Advisor client.

A set of pre-configured templates in Performance Advisor is known as
Predefined Template.
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How to send your comments
You can help us to improve the quality of our documentation by sending us your feedback.
Your feedback is important in helping us to provide the most accurate and high-quality information.
If you have suggestions for improving this document, send us your comments by email to
doccomments@netapp.com. To help us direct your comments to the correct division, include in the
subject line the product name, version, and operating system.
You can also contact us in the following ways:
•
•
•
•

NetApp, Inc., 495 East Java Drive, Sunnyvale, CA 94089 U.S.
Telephone: +1 (408) 822-6000
Fax: +1 (408) 822-4501
Support telephone: +1 (888) 463-8277
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